Reply

500 error with WAPI paging request

Member
Posts: 2
381     0

We are running into a 500 error that when making a paging request via the WAPI. Following the example for Sample paging request (pages 75-78) in https://www.infoblox.com/wp-content/uploads/infoblox-deployment-infoblox-rest-api.pdf, we receive a 500 error and 

{ "Error": "AdmConError: None ('NoneType' object has no attribute 'key')", 

  "code": "Server.Ibap.Internal", 

  "text": "Internal Error", 

  "trace": "  File \"ibapapachemod.py\", line 470, in handlerequest\n  File \"/infoblox/common/lib/python/infoblox/one/admin_conn/wapibase.py\", line 1485, in execute\n  File \"/infoblox/common/lib/python/infoblox/one/admin_conn/wapibase.py\", line 1439, in _exec_handler\n  File \"/infoblox/common/lib/python/infoblox/one/admin_conn/wapihandler.py\", line 887, in execute\n  File \"/infoblox/common/lib/python/infoblox/one/wapibaseobj.py\", line 1340, in read\n  File \"/infoblox/common/lib/python/infoblox/one/base.py\", line 1866, in filter_reader\n  File \"/infoblox/common/lib/python/infoblox/dns/host_record.py\", line 4831, in filter\n  File \"/infoblox/common/lib/python/infoblox/dns/dhcp_common.py\", line 7325, in check_non_dns_host_ro_permission\n"

}

we are making the rerquest with 

curl --location --request GET 'https://infoblox.domain.com/wapi/v2.10/record:host?_paging=1&_return_as_object=1&_max_results=1000&_page_id=

789c5590c16ec3200c86ef7e91e41485245d9bbd412ed5b43e00224032a60423205afbf6b3d9b46a17243effc69fa94d1070ab30da7c442f17673793e48e2655103aaa54906ed54e7519d46a99f630b582a98a2bdf07a84d389598bacb58322f3089b66d19729b747e41c267d01ac383422bd0a1d1a71c0f9d3142b840ad39366f786fd0db6656c9c21b754f44218ca0a59c0fb765e7a5049c3fadce10440bd7fc1e84600bc1c60bc62f150d8d137faa29ab98990c300dbf629bdb5d61a7a7ec8a1965c0e4b2432f7159922d11daa71fc791234665c5e85c065e20cd04c9263f82653e9202af16cdeb0726eeeecad3ffbf98b1802bab1df31375fc68d7737e71f1a79b9459aef906e74183c8-7b7ac17f6801856ef43615bd15939cb1e2b3ea5cbdb0c89d6f54a6c' --header 'Authorization: Basic validtokennnnnnnnnnnnnnnnnn=' -k

We are not getting the error requesting A records. This happens with the 5th request.

Any ideas?

 

 

Re: 500 error with WAPI paging request

Member
Posts: 2
381     0

Anyone?

Re: 500 error with WAPI paging request

Adviser
Posts: 201
382     0

Hi,

 

I would suggest opening a support ticket to help debug this further.

 

Regards,

Krishna Vasudevan

Showing results for 
Search instead for 
Did you mean: 

Recommended for You