API & Integration

Reply

Infoblox integration with Rapid7 InsightVM (Nexpose) Troubleshooting

[ Edited ]
jjpeter1
Techie
Posts: 1
662     0

Hello everyone!

 

I am attempting to integrate Infoblox with InsightVM and have followed the guides/templates provided on these forums.  Based on our logs, our login/logoff is working flawlessly, however we are having issues with anything past that.  

 

When triggering a notification based on a DHCP Lease event, there appears to be an error in the "assignLVarsLease" step that is causing the error "Invalid variable E:values".  I placed the logs below.  Any help is appreciated.

 

(DEBUG): Executing step skip object modification (1)
(DEBUG): Found a/an AND condition step!
(DEBUG): Evaluating statement:  == MODIFY
(DEBUG): The condition did not match!
(DEBUG): Executing step defaultValues (1)
(DEBUG): Executing step checkEType_Network (1)
(DEBUG): Found a/an AND condition step!
(DEBUG): Evaluating statement: LEASE == LEASE
(DEBUG): The condition matched!
(DEBUG): Jumping to to checkEType_Lease
(DEBUG): We are jumping from step checkEType_Network (#2), to checkEType_Lease (#22)
(DEBUG): Executing step checkEType_Lease (1)
(DEBUG): Found a/an AND condition step!
(DEBUG): Evaluating statement: LEASE != LEASE
(DEBUG): The condition did not match!
(DEBUG): Executing step skip if not defined for lease (1)
(DEBUG): Found a/an OR condition step!
(DEBUG): Evaluating statement: Infoblox Integration == 
(DEBUG): Evaluating statement: true == 
(DEBUG): Evaluating statement: true == false
(DEBUG): The condition did not match!
(DEBUG): Executing step assignLVarsLease (1)
(DEBUG): An error has occurred while processing a template
(DEBUG): Invalid variable E:values
(DEBUG): The namespace E contains the following data {u'protocol': u'IPv4', u'event_type': 'LEASE', u'fingerprint_os_number': u'1701', u'ip.extattrs': {u'R7_ScanTemplate': u'default', u'R7_Site': u'Infoblox Integration', u'R7_AddByHostname': u'true', u'R7_ScanOnEvent': u'true', u'R7_NetToSite': u'true', u'R7_Sync': u'true', u'R7_RangeToSite': u'true', u'R7_ScanOnAdd': u'true', u'R7_SiteID': u'0'}, u'ip.username': u'', u'thread_id': 0, u'member_name': u'test.com', u'range_end_addr': u'192.168.150.250', u'network': u'192.168.150.0/24', u'ip.names': [], 'network_netmask': 24, u'ends': u'2018-07-31T18:31:39Z', u'range_start_addr': u'192.168.150.20', u'network.extattrs': {u'R7_RangeToSite': u'true', u'Site Code': u'MKE', u'R7_Site': u'Infoblox Integration', u'R7_AddByHostname': u'true', u'Region': u'NA', u'R7_SiteID': u'0', u'R7_ScanOnAdd': u'true', u'Device Type': u'lab subnet', u'Special Zone': u'not a special zone', u'R7_ScanTemplate': u'default', u'Device Ownership': u'owned by RA', u'R7_ScanOnEvent': u'true', u'R7_Sync': u'true', u'IP range Registered': u'Private Range', u'R7_LastScan': u'0', u'Allocation Status': u'Allocated', u'R7_NetToSite': u'true'}, u'timestamp': u'2018-07-31T18:29:39Z', u'vnode_oid': 0, u'sequence_id': 142591, 'network_ipaddr': '192.168.150.0', u'fingerprint': u'PXE', u'hardware': u'1C:C1:DE:01:5E:C0', u'member_ip': u'10.10.10.10', u'network_view': u'default', u'starts': u'2018-07-31T18:29:39Z', u'client_hostname': u'dhcp-192-168-150-250', u'network_view_id': u'0', u'binding_state': u'OFFERED', u'address': u'192.168.150.250'}
(DEBUG): Execution failed, retry if 0 < 0
(WARNING): Template execution retry limit is reached.Event `{u'protocol': u'IPv4', u'event_type': 'LEASE', u'fingerprint_os_number': u'1701', u'ip.extattrs': {u'R7_ScanTemplate': u'default', u'R7_Site': u'Infoblox Integration', u'R7_AddByHostname': u'true', u'R7_ScanOnEvent': u'true', u'R7_NetToSite': u'true', u'R7_Sync': u'true', u'R7_RangeToSite': u'true', u'R7_ScanOnAdd': u'true', u'R7_SiteID': u'0'}, u'ip.username': u'', u'thread_id': 0, u'member_name': u'test.com', u'range_end_addr': u'192.168.150.250', u'network': u'192.168.150.0/24', u'ip.names': [], 'network_netmask': 24, u'ends': u'2018-07-31T18:31:39Z', u'range_start_addr': u'192.168.150.20', u'network.extattrs': {u'R7_RangeToSite': u'true', u'Site Code': u'MKE', u'R7_Site': u'Infoblox Integration', u'R7_AddByHostname': u'true', u'Region': u'NA', u'R7_SiteID': u'0', u'R7_ScanOnAdd': u'true', u'Device Type': u'lab subnet', u'Special Zone': u'not a special zone', u'R7_ScanTemplate': u'default', u'Device Ownership': u'owned by RA', u'R7_ScanOnEvent': u'true', u'R7_Sync': u'true', u'IP range Registered': u'Private Range', u'R7_LastScan': u'0', u'Allocation Status': u'Allocated', u'R7_NetToSite': u'true'}, u'timestamp': u'2018-07-31T18:29:39Z', u'vnode_oid': 0, u'sequence_id': 142591, 'network_ipaddr': '192.168.150.0', u'fingerprint': u'PXE', u'hardware': u'1C:C1:DE:01:5E:C0', u'member_ip': u'10.10.10.10', u'network_view': u'default', u'starts': u'2018-07-31T18:29:39Z', u'client_hostname': u'dhcp-192-168-150-250', u'network_view_id': u'0', u'binding_state': u'OFFERED', u'address': u'192.168.150.250'}` is skipped

 

Re: Infoblox integration with Rapid7 InsightVM (Nexpose) Troubleshooting

nwalters
Techie
Posts: 1
663     0

Hello,

 

Do you have the extensible attrtibutes configured and inheritance enabled? That would be a good first step in troubleshooting this issue. 

 

If that doesn't help, can you post the full debug log?

Showing results for 
Search instead for 
Do you mean 

Recommended for You