Issues with Ansible nios_txt_record Infoblox module

Posts: 1
191     0



I'm from the Red Hat's Ansible support team. I've opened this request as part of partner engagement with Infoblox on behalf of a customer. We have two cases with us by a customer. The customer is having issues with the Infoblox Ansible module nios_txt_record


`Ansible nios_txt_record module replaces existing TXT records instead of adding additional records.`


Details about the issues can be found in the below link opened in our Ansible Github repository .


We had pinged Sailesh Giri and Kris Vasudevan on our Ansible Github issue link to get someone to work on the Infoblox module but haven't got a reply. I've gone through a support case with Infoblox but they have redirected me here. The Infoblox modules are certified and provided by Infoblox as part of our partner program. We are requesting a collaboration on the issue mentioned above to get a fix out for the module. Ansible will do the needful to include in the applicable releases once a suitable fix is provided.



Ishwar Kanse

Senior Technical Support Engineer,

Red Hat

Re: Issues with Ansible nios_txt_record Infoblox module

Ingmar Community Manager
Community Manager
Posts: 71
191     0

it looks like this depends on


This module does not support txt records, I have just made a pull request to include them. Once that gets merged the behavior should be in line with expectations.




Re: Issues with Ansible nios_txt_record Infoblox module

Posts: 1
191     0

You are wrong.  The nios_txt_record module was introduced in Ansible 2.7:


The problem is the TXT module was never tested before it was released into production.  Infoblox releases alpha quality code to the community and then takes months to fix problems after they are reported.


I reported back in January that you couldn't add the same record to two different views using nios_a_record, even though it specifically supported views.  That didn't get fixed until mid-March.


 nios_a_record fails adding same A record to different view. #51204 


Turns out the same problem exists with the nios_ptr_record module too:


Nios_ptr_record fails adding same PTR record to different views. #58378 


The problem with nio_ptr_record was reported in June and it's still not fixed!  Based on past history, I can expect a fix for nios_txt_record sometime next spring.


Infoblox signed on to the Red Hat Red Hat Ansible Automation Certification Program and promised to "provide tested, trusted and supported solutions for automating across environments at scale"


As a paying Infoblox customer who has worked with your Ansible NIOS modules, I can attest to the fact that Infoblox's Ansible modules are NOT TESTED, CANNOT BE TRUSTED AND ARE NOT SUPPORTED.





Re: Issues with Ansible nios_txt_record Infoblox module

[ Edited ]
Posts: 1
192     0

Any updates?


The customer (WRJFontenot) is still waiting.



Takashi Sugimura

Technical Support Engineer, Ansible

Red Hat


Showing results for 
Search instead for 
Do you mean 

Recommended for You