Reply
Accepted Solution

NIOS Upgrades and APIs

campbrs
Techie
Posts: 7
2565     0

Why do we need to upgrade the Perl API's with every NIOS upgrade?  Is there a way around this?

 

Does the WAPI have a similar constraint where I would need to update URI's in my scripts to reflect the new version of the API or are "links or redirects" in place to forward the request to the new URI?

 

Thanks,

RC

Re: NIOS Upgrades and APIs

Moderator BRampling
Moderator
Posts: 69
2566     0

The Perl module is updated to add the new API functions with each release, this is why it needs to be updated each time.

 

The WAPI has no such constraint. I just tested a WAPI call (get networks) against a NIOS 8.0 appliance (WAPI v2.5) and used the URL for the WAPI version all the way back to v1.0 and it worked fine. The only reason you need to use the newer version in your URL is if you need to use a WAPI request that was implemented in a newer version.

 

I would recommend all customers eventually move to WAPI over the Perl API. 

Showing results for 
Search instead for 
Do you mean 

Recommended for You