Retrieving DNS records with WAPI

[ Edited ]
Posts: 2
7247     0

I encountered a problem using WAPI to retrieve DNS records in Infoblox 6.9 grid.

The configuration includes several views (3), including many authoritative zones, with sub-zones.
These zones contain lot of records :
 - MX Records
 - NS Records
 - A Records
 - CNAME Records
 - Host Records

I want to retrieve all the records, by type and by zone, using WAPI in PowerShell.
Using the PowerShell script (v1.11.19 with PowerShell V4), I can retrieve some records with the IB-Search function, but there are a lot of missing records.

I tried to retrieve the Informations directly from a browser, using syntax like https://GridIPAddress/wapi/v1.3/record:host, but there are also lot of records missing.

It seems that is related to the different views.
I tried a syntax like https://GridIPAddress/wapi/v1.3/record:host?view=view1, but I retrieved only 1 record, none from the zones or sub-zones.

Is there a syntax to retrieve all the records of the zones (zone by zone, or globally) inside a view ?


Re: Retrieving DNS records with WAPI

[ Edited ]
Posts: 18
7247     0

Hi PDutel, what you attempted should have worked, I just tried the same search (for now simply posting this URL in my browser) using the 'default' view and got all host records back:




You also may want to make sure you are searching for the right type of DNS record, as your Grid may contain only 1 host record (but several A/PTR records for example):





Re: Retrieving DNS records with WAPI

Posts: 2
7247     0



Sorry for delay, i was out of office for 1 month.

I tried the solution you suggested, but still without success.


The syntax https://IPGrid/wapi/v1.3/record:a?_return_type=json-pretty&view=view2 returns only 2 records : the DNS themselves.


If I check in the Grid Manager, clicking on the DataManagement/DNS/View link, I have about 30 Authoritative zones. Each of these zones have several (more than 100) A Records (plus NS, MX, SOA, SRV, TXT, CNAME), but I can't retrieve them, either through the navigator, nor through the Powershell API.


I tried to add the authoritative zone in the request, like https://IPGrid/wapi/v1.3/record:a?_return_type=json-pretty&view=view2&zone=zoneX, without success (I just retrieve a screen with




Any idea ?


Best regards


Showing results for 
Search instead for 
Did you mean: 

Recommended for You