3 weeks ago
A few days ago infoblox-client 0.4.24 was released.
I wanted to update from 0.4.23 on my Ubuntu 18.04 and don't wanted to destroy OS-maintained packages. While doing this, I found that python-six 1.13 is required in the dependencies. But in Ubuntu there is only 1.11 available. Other OSes also don't deliver 1.13, e.g. in Debian 10 it's 1.12. That means six has to be upgraded outside the OS on nearly any Linux environment.
Question for the developers: Is six 1.13 really necessary? Do you use any features from 1.12 or 1.13?
Infoblox-client 0.4.23 was running fine with six 1.11...
Do you think it's save to modify the required dependency back to 1.11?