Learn How We Can Help You Keep Teleworkers Protected During the COVID-19 Crisis

API & Integration

Reply
Highlighted

infoblox-client 0.4.24 dependency question

Authority
Posts: 25
173     0

A few days ago infoblox-client 0.4.24 was released.

I wanted to update from 0.4.23 on my Ubuntu 18.04 and don't wanted to destroy OS-maintained packages. While doing this, I found that python-six 1.13 is required in the dependencies. But in Ubuntu there is only 1.11 available. Other OSes also don't deliver 1.13, e.g. in Debian 10 it's 1.12. That means six has to be upgraded outside the OS on nearly any Linux environment.

 

Question for the developers: Is six 1.13 really necessary? Do you use any features from 1.12 or 1.13?

Infoblox-client 0.4.23 was running fine with six 1.11...

Do you think it's save to modify the required dependency back to 1.11?

 

Highlighted

Re: infoblox-client 0.4.24 dependency question

Authority
Posts: 25
174     0

The recently released version 0.4.25 has the same dependencies.

 

@Infoblox: Any thoughts about this?

 

Showing results for 
Search instead for 
Do you mean 

Recommended for You