Reply

Bind config on win ser 2012 not working

rameshwar
Techie
Posts: 12
759     1
We have installed bind on server 2012 the service was not starting and named.conf file was not created . We created the file as txt and renamed to conf by adding the parameters n then service was started but still server is not sending dns to infoblox when we try nslookup from client machine .. also changed fhe lan ip to infoblox ip on server but no luck plz advise if there is any document for this setup

Re: Bind config on win ser 2012 not working

JJGarsia
Techie
Posts: 3
759     1

If during normal loading you can open bind (via the task manager - file - execute) then execute -

net start netlogon

It will not start and the cause of the error must be registered in the logs (although it should be so anyway)

And show the output of commands

sc qc netlogon
sc qc LanmanServer
sc qc LanmanWorkstation

It is about the same as below, copy and change to what you have (if you can not copy from the server)

C: \ Users \ Administrator> sc qc netlogon
[SC] QueryServiceConfig: Success

ServiceName: netlogon
        Type: 20 WIN32_SHARE_PROCESS
        Start_type: 2 AUTO_START
        Bug Management: 1 NORMAL
        Binary_name: C: \ Windows \ system32 \ lsass.exe
        Startup Group: MS_WindowsRemoteValidation
        Tag: 0
        Display_Name: Network Login
        Dependencies: LanmanWorkstation
                             : LanmanServer
        Service_start_name: LocalSystem

C: \ Users \ Administrator> sc qc LanmanServer
[SC] QueryServiceConfig: Success

ServiceName: LanmanServer
        Type: 20 WIN32_SHARE_PROCESS
        Start_type: 2 AUTO_START
        Bug Management: 1 NORMAL
        Binary_name: C: \ Windows \ system32 \ svchost.exe -k netsvcs
        Startup Group:
        Tag: 0
        Display_name: Server
        Dependencies: SamSS
                             : Srv2
        Service_start_name: LocalSystem

C: \ Users \ Administrator> sc qc LanmanWorkstation
[SC] QueryServiceConfig: Success

ServiceName: LanmanWorkstation
        Type: 20 WIN32_SHARE_PROCESS
        Start_type: 2 AUTO_START
        Bug Management: 1 NORMAL
        Binary_name: C: \ Windows \ System32 \ svchost.exe -k NetworkService

        Startup Group: NetworkProvider
        Tag: 0
        Display_name: Workstation
        Dependencies: Bowser
                             : MRxSmb20
                             : NSI
        Initial Service_Name: NT AUTHORITY \ NetworkService

C: \ Users \ Administrator>

Re: Bind config on win ser 2012 not working

rameshwar
Techie
Posts: 12
759     1
Hi

Thanks for the post but m confuse here ... what exactly i have to do ? Should i go to c/user/admin path n copy this parameter? Or u r asking for the output of the above command which u have mentioned .... the issue is bind service seems to be running and also i can see named.exe in process but bind i.e server is not sending traffic to infoblox

Re: Bind config on win ser 2012 not working

[ Edited ]
alexstephen
Techie
Posts: 1
759     1
 

There are very good reasons to have recursive lookups go through BIND, notably the ability to filter and rate limit external queries. In the current age where the favorite DOS attack seems to be DNS amplification, this is critical. Also, you might be justifiably concerned about having your AD domain controllers relatively open in the Internet.
You can set up zone transfers to only be allowed to your secondary. That should make you feel better about the xfer.

You still should have at least two domain controllers! But not so one is available for external lookups.

Blogger, entrepreneur and academic writer to write my essay.

 

<Moderator> External link removed.

Re: Bind config on win ser 2012 not working

[ Edited ]
Posts: 1
759     1

It's not working on old windows. Since the new update has launched. Try to reinstall the win server 2012 again and check if its work. The same thing happened in our free essay writer/7$ website. It was not uploading and we stuck at one point. Orders were delayed. Glad we came out of that situation early. Simply reinstalled the server configure with current windows update. Hope it will work for you!

 

<Moderator> External link removed

Re: Bind config on win ser 2012 not working

[ Edited ]
Posts: 1
759     1

I am sure someone will offer some possible solutions soon.

Re: Bind config on win ser 2012 not working

[ Edited ]
nashimir
Techie
Posts: 2
759     1

I have a couple of Active Directory domains here. All of my domain controllers (and DNS servers) are running Windows Server 2008 R2 x64 SP1. I have just started experimenting with Windows Server 2012 R2, and am trying to learn my way around it.

 

<Moderator> External links removed.

Highlighted

Re: Bind config on win ser 2012 not working

TTiscareno Community Manager
Community Manager
Posts: 322
759     1

Without commenting on the merits of running BIND on Windows or Windows DNS- there are many reasons for why BIND may fail to start or not send traffic. This can be anything from a formatting error with your named.conf or zone data files, the local firewall is blocking the DNS ports, or even that the Windows DNS service is already running and is preventing BIND from being able to grab the port(s) that it needs.

 

To troubleshoot the issue, you will need to go through your configuration and application/system logs in detail. If the server is working but traffic is not going out, a network sniffer might be needed to see if the server is doing anything with traffic and if so, where is it going. These troubleshooting steps can be difficult and is why Infoblox goes to great lengths to provide a solution that is effective, easy to implemt and troubleshoot, and a world-class support organization available to help Infoblox customers with maintaining their deployments.

 

You do not mention how you are trying to send traffic to your Infoblox server(s) but based on the limited information available here, I would suspect an issue with the named.conf file. To check for errors with the named.conf file, use the named-checkconf command (https://ftp.isc.org/isc/bind9/9.9.7rc1/doc/arm/man.named-checkconf.html). If you are trying to forward queries to Infoblox, recursion must be enabled. Example:

 

--------------------------------------

options {
directory "/var/cache/bind";

recursion yes;
allow-query { any; };

forwarders { 10.64.12.13; };

forward only;

};

--------------------------------------

 

Since this is specifical to your BIND configuration, the ISC bind-users mailing list (https://lists.isc.org/mailman/listinfo/bind-users) may be a better resource to ask for assistance with troubleshooting this.

 

Regards,

Tony

Showing results for 
Search instead for 
Do you mean 

Recommended for You