DNS DHCP IPAM

Reply

Can't delete A record - auto created by add zone

[ Edited ]
JD
Techie
Posts: 3
2150     0

Hi

 

Hope you can help me. I am trying to delete some A records, however this isn't possible. I get the following error "System-generated records cannot be modified". I can see that the record is "auto created by add zone".

 

I have been searching for solutions, but none I found did the trick. 

 

I have also tried this:

set maintenancemode

set dns-auto-check renew

 

I've got the following entry when running the "set dns-auto-check renew" for some of the entries I am trying to delete:

missing PTR ._default.arpa.in-addr.1.2.3.x.somename.com found

 

Any recommendation as to what to do next would be greatly appreciated.

 

Best regards

JD

Re: Can't delete A record - auto created by add zone

[ Edited ]
JD
Techie
Posts: 3
2150     0

No one able to help? It would be greately appreciated Smiley Happy

Highlighted

Re: Can't delete A record - auto created by add zone

Adviser
Posts: 81
2150     0

Hi JD,

 

This is a fairly common question and you can find quite a bit of information on this in the Infoblox knowledge base, such as https://support.infoblox.com/app/answers/detail/a_id/122/kw/auto%20created%20record/.

 

In general, auto created records are generated whenever a zone configuration calls for it. For example, when you assign a name server to a zone or for a delegation, the 'glue' record (such as this A record) required for that configuration to work is automatically added for you. To remove that A record, you would need to remove the name server from the zone(s) that it is assigned to and after it is removed from all configurations, the automatically created records would be removed as well. This can be a little tricky to do in some configurations so you can try running a search using the global search tool (magnifying glass at the top right hand corner of your Grid Manager GUI) and search for the name or IP for this A record. This should help narrow things down for you.

 

One exception to this is that there is the possibility that the tie between the name server configuration and the record has been broken in the database (usually a factor from older versions of NIOS). In this scenario, you would need to connect to the CLI (SSH) for your Grid Master and leverage the command "set dns-auto-gen renew". This must be run in maintenance mode, which you can enter by using the command "set maintenancemode" (note: maintenance mode does not change the way the server works, only the commands that are available to you in the current CLI session).

 

Hopefully this helps you with being able to clean this up. If you need any further assistance, Infoblox Support (https://support.infoblox.com/) will be happy to help out you more.

Re: Can't delete A record - auto created by add zone

JD
Techie
Posts: 3
2151     0

Hello TTiscareno

 

Thank you very much for your reply. Unfortunately I wasn't able to fix this based on your good suggestions. When doing a search, I get an A-record, PTR-record and an IP address for one of the hosts. I could delete the PTR, but I can't delete the A record. I am not able to find any clues as to why it's status is "auto created". The CLI workaround didn't seem to help either (had tried it before actually).

 

Well I guess I have to try Infoblox support. 

 

Again, thank you for your effort Smiley Surprised)

 

JD

Re: Can't delete A record - auto created by add zone

BHanson
Techie
Posts: 7
2151     0

DANGER DANGER DANGER..  well beware of that utility.... while it fixes some things it has broken others for us...

 

there HAS to be a way to remove these without running that utility..

 

so the utility ADDED 'A' records for our LAN2 interface that is serving DNS.. But the options set did not have that checked and it should not have added it.

 

then we also have RPZ zones defined.  It removed the NS records for that....

 

overall a utility that breaks more than it fixes .. at least in our use situation....

(posted again here and in other similar posts in the forum).

 

Re: Can't delete A record - auto created by add zone

Adviser
Posts: 81
2151     0

BHanson wrote:

DANGER DANGER DANGER..  well beware of that utility.... while it fixes some things it has broken others for us...

 

there HAS to be a way to remove these without running that utility..

 

so the utility ADDED 'A' records for our LAN2 interface that is serving DNS.. But the options set did not have that checked and it should not have added it.

 

then we also have RPZ zones defined.  It removed the NS records for that....

 

overall a utility that breaks more than it fixes .. at least in our use situation....

(posted again here and in other similar posts in the forum).

 


I believe that there may be some confusion here. You don't specifically call out which utility you are referring to but I am assuming that this is the CLI command "set dns-auto-gen". Taking a step back- in NIOS, all objects in the database leverage a reference ID when establishing relationships. An issue which is more commonly encountered in older versions of NIOS (and only noticed later on), the reference ID can become invalid and a corresponding 'auto created' record becomes orphaned, or is not created at all.


What "set dns-auto-gen" command does is analayze all of these reference ID's and identifies ones where an associated auto generated record should exist but doesn't and creates it, or if an auto created record exists where no valid reference ID can be found, it is removed and which is what all of the posts that you are referencing are looking for help with.


In the community forums here, a level of troubleshooting which would be required to identify whether the auto created record has become orphaned is not generally done so the recommendation for using the "set dns-auto-gen" command is provided only as an option, not necessarily the solution. There are a number of things that can cause the auto-created record to be present and many of these are normal configurations where the configuration itself needs to be updated. As it can be any number of configurations which can cause a single auto created record to be generated, these can sometimes be difficult for an administrator to identify and in those cases, the referenced command would not be of any benefit.


If you have identified occurrences where the command removed records incorrectly, you should report these to Infoblox Support. This way, either an issue can be identified and corrective action can be taken so that no one else will experience the same issue, or a different issue with your configuration or steps that you are taking can be identified and Infoblox Support will be able to assist you with correcting that.

Re: Can't delete A record - auto created by add zone

spenumaka Community Manager
Community Manager
Posts: 53
2151     0

Hi - This question is repeated multiple times and it was answered here.

 

https://community.infoblox.com/t5/DNS-DHCP-IPAM/need-to-delete-ns-record-auto-created-by-add-zone/m-...

 

Thanks,

Check out our new Tech docs website at http://docs.infobox.com for latest documentation on Infoblox products.

Re: Can't delete A record - auto created by add zone

[ Edited ]
ÅNordin_1
Techie
Posts: 1
2151     0

I have roughly the same problem: We moved one in a set of nameservers for four domains (one forward and three IPv4 reverse domains) to another network. The server did not change name, only IP address.

 

The old IP lingers on as an A record, and is returned together with the valid glue in the additional section of NS queries.

 

After reading the previous information in this thread, I removed the moved server from all delegations and ran set dns-auto-gen check in maintenance mode. While it correctly identified both A records of the moved server as obsolete, both returned to occur in the additional section of NS answers when I added the moved server back to those delegations.

 

We're on NIOS 8.0.6 now. The database is originally from before NIOS 6. I think we were on NIOS 7.3 something when the server move was performed.

 

Any further clues?

Re: Can't delete A record - auto created by add zone

Ingmar
Techie
Posts: 11
2151     0

ÅNordin_1 wrote:

 

...

After reading the previous information in this thread, I removed the moved server from all delegations and ran set dns-auto-gen check in maintenance mode. While it correctly identified both A records of the moved server as obsolete, both returned to occur in the additional section of NS answers when I added the moved server back to those delegations.

...

 

 

In order to resolve the issue, you should be running "set dns-auto-gen renew". When you run dns-auto-gen check the command will only perform an analysis of the records without making any changes to the database. 

Showing results for 
Search instead for 
Do you mean 

Recommended for You