Reply
Accepted Solution

DHCP not working

rajdsing
Not applicable
Posts: 0
108     0

Hi Experts,

 

Just tried setting up a DHCP pool but I am unable to get DHCP to work. I ran a tcpdump from infoblox CLI and can see the DHCP discover coming in but infoblox doesnt send out a reply. Any ideas what am i missing?

 

Expert Mode > tcpdump -i eth3 host 10.101.114.1

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

listening on eth3, link-type EN10MB (Ethernet), capture size 262144 bytes

23:52:35.386043 IP 10.101.114.1.67 > 71.1.1.11.67: BOOTP/DHCP, Request from 00:50:56:bb:61:0b (oui Unknown), length 309

23:52:37.717025 IP 10.101.114.1.67 > 71.1.1.11.67: BOOTP/DHCP, Request from 00:50:56:bb:61:0b (oui Unknown), length 309

23:52:41.287657 IP 10.101.114.1.67 > 71.1.1.11.67: BOOTP/DHCP, Request from 00:50:56:bb:61:0b (oui Unknown), length 309

23:52:47.770612 IP 10.101.114.1.67 > 71.1.1.11.67: BOOTP/DHCP, Request from 00:50:56:bb:61:0b (oui Unknown), length 309

23:52:50.703353 IP 10.101.114.1.67 > 71.1.1.11.67: BOOTP/DHCP, Request from 00:50:56:bb:61:0b (oui Unknown), length 309

23:52:58.794134 IP 10.101.114.1.67 > 71.1.1.11.67: BOOTP/DHCP, Request from 00:50:56:bb:61:0b (oui Unknown), length 309

^C

6 packets captured

6 packets received by filter

0 packets dropped by kernel

 

 

Here is my DHCP pool config:

 

ddns-update-style interim;
log-facility local7;
# log lease events
# fingerprinting enabled;
local-address 71.1.1.11;
server-identifier 71.1.1.11;
not authoritative;
infoblox-ignore-uid false;
infoblox-ignore-macaddr false;
default-lease-time 43200;
min-lease-time 43200;
max-lease-time 43200;
one-lease-per-client false;
ping-number 1;
ping-timeout-ms 1000;
omapi-key DHCP_UPDATER;
omapi-port 7911;

ddns-updates off;
ignore client-updates;

include "/infoblox/var/dhcpd_conf/dhcp_updater.key";

# set lt (a printable version of the lease time) to either the actual lease time, or undefined 
set lt = pick(binary-to-ascii(10, 32, "", option dhcp-lease-time), "undefined");

if (exists agent.circuit-id and exists agent.remote-id) {
	log(info,
		concat("Option 82: ",
			"received a REQUEST DHCP packet from relay-agent ",
			binary-to-ascii(10, 8, ".", packet(24, 4)),
			" with a circuit-id of \"",
			binary-to-ascii(16, 8, ":", option agent.circuit-id),
			"\" and remote-id of \"",
			binary-to-ascii(16, 8, ":", option agent.remote-id),
			"\" for ",
			binary-to-ascii(10, 8, ".", leased-address),
			" \(", binary-to-ascii(16, 8, ":", packet(28,6)), "\)",
			" lease time is ", lt, " seconds."
			)
		);
}

else if exists agent.circuit-id {
	log(info,
		concat("Option 82: ",
			"received a REQUEST DHCP packet from relay-agent ",
			binary-to-ascii(10, 8, ".", packet(24, 4)),
			" with a circuit-id of \"",
			binary-to-ascii(16, 8, ":", option agent.circuit-id),
			"\" for ",
			binary-to-ascii(10, 8, ".", leased-address),
			" \(", binary-to-ascii(16, 8, ":", packet(28,6)), "\)",
			" lease time is ", lt, " seconds."
			)
		);
}

else if exists agent.remote-id {
	log(info,
		concat("Option 82: ",
			"received a REQUEST DHCP packet from relay-agent ",
			binary-to-ascii(10, 8, ".", packet(24, 4)),
			" with a remote-id of \"",
			binary-to-ascii(16, 8, ":", option agent.remote-id),
			"\" for ",
			binary-to-ascii(10, 8, ".", leased-address),
			" \(", binary-to-ascii(16, 8, ":", packet(28,6)), "\)",
			" lease time is ", lt, " seconds."
			)
		);
}

subnet 10.101.114.0 netmask 255.255.255.0 {
	 not authoritative;
	option domain-name "nychhc.local";
	option domain-name-servers 71.1.1.11;
	option routers 10.101.114.1	;
	default-lease-time 43200;
	min-lease-time 43200;
	max-lease-time 43200;
}

subnet 71.1.1.0 netmask 255.255.255.0 {
	not authoritative;
}

#End of dhcpd.conf file

 

Highlighted

Re: DHCP not working

Adviser
Posts: 65
108     0

In the configuration file i'm missing the DHCP range. Did you configure and assigned it to the DHCP server? Guess not

Re: DHCP not working

rajdsing
Not applicable
Posts: 0
109     0

Thanks Harry!

 

Adding the range fixed it! 

 

 

Showing results for 
Search instead for 
Do you mean 

Recommended for You