Reply

DIW connection timeout during import

[ Edited ]
Authority
Posts: 18
2968     0

Hello,

we are having another issue with the importer: it fails to import a small zone to our grid master.

Everything is ok until I press the import button, it then creates the zone we are importing and then it gets stuck and after a while giving a "connection lost" error. There is no network issue of course and it works perfectly to import our dhcpd.conf that is a long running task (3-4 minutes).

I have tried many times but it always stop. Log is clean.

 

Any suggestion on what might be happening?

 

Best,

Marco

Re: DIW connection timeout during import

Expert
Posts: 292
2969     0

I had a similar issue just recently, despite setting the inactivity timeout to 3600 the DIW would disconnect whilst trying to import the first zone in a list of zones. However it did set grid options, so it did actually start processing data. I also checked the log and didn't find anything that could indicate why the connection was terminated,

 

I never got to the bottom of it, I was using DIW over the internet to import data into a customer's grid so I assumed it was an issue with their firewall doing something strange with my connection (maybe it thought there was a data exfiltration attack going on and terminated the connection).

 

To get around the problem I took a grid back from the customer, loaded it up in VMware in my lab, ran DIW locally (which worked fine), took a grid backup of my lab and then loaded this onto the customer's grid. That all worked fine so I moved onto the next job and forgot about this until I just read your post.

 

Maybe someone else has an idea?

Paul Roberts
PCN (UK) Ltd

All opinions expressed are my own and not representative of PCN Inc./PCN (UK) Ltd. E&OE

Re: DIW connection timeout during import

Community Manager
Community Manager
Posts: 248
2969     0

What about the syslog of the GM, are there any clues there.

 

You can also look at the debug log from the console (show log debug) that often has some clues from the DIW.

 

It all depends on the content of the zone:

  • was it a subzone that required moving a lot of parent records into it?
  • was it a zone with a lot of delegations?
  • Did you ask it to create hosts and now it has to walk the entire database looking for links ?
  • etc

 

Timeouts usually occur when the grid has to do a lot of processing of the zone to move data around.

  

Showing results for 
Search instead for 
Did you mean: 

Recommended for You