Reply

DNS Forwarding correct method

[ Edited ]
waleedosama
Techie
Posts: 3
4846     0

Dears,

I'm doing some testing in my Lab.

I have  a Authoritative Forward Zone test.com.

I want this zone to answer queries only to *.test.com and nothing to the internet. And this works fine.

I also created another zone, that forward queries to anything thats not in *.test.com (or that is my objective) to google DNS Servers.

So on the Grid Member, I disabled recursion, since I don't want Infoblox to do recursive queries.

On DNS Grid Properties I also disabled recursion.

From my understanding, regarding the forwarding, there are 2 methods.

1- Create a forward zone, assign google's 8.8.8.8 as forwarder and assign a grid member,

----This didn't work, I get a "REFUSED" response when I query the internet

2- On the DNS Grid Properties, add a forwrarder which is Google' 8.8.8.8, still didn't work.

The interesting thing is, I can go query the internet, without both options, if I only allow recursion on the grid member. Which isn't what I want.

I want infoblox to act just like a home router and forward queries it doesn't have to the internet.

Appreciate the help.

Re: DNS Forwarding correct method

Expert
Posts: 227
4847     0

You'll need to enable recursion in order to do forwarding.

Paul Roberts
PCN (UK) Ltd

All opinions expressed are my own and not representative of PCN Inc./PCN (UK) Ltd. E&OE
Showing results for 
Search instead for 
Do you mean 

Recommended for You