Reply

Delegation zone not working

Techie
Posts: 2
3825     0

Hello everybody,

 

 

I just joined this community as I am stuck with a problem. I've checked for similar post but could not find it, maybe because it is a very newbie problem.

 

The thing is I have a working grid with a delegation zone (zone A) to another infoblox appliance (DNS A). With this scenario I had to configure a new delegation zone (zone B) pointing to a new DNS B. When I test it, I get NX domain.

 

If I do a tcpdump I see Infoblox asking the resolution of this zone B to the wrong DNS the A, even though I have configured the B. I do not know what I am missing.

 

Thanks in advance for your help!

 

Regards

Re: Delegation zone not working

Authority
Posts: 18
3825     0

Hi!

 

 

Idealy, the server is no expected to resolve the query of one delegation zone against the server of another delegation. 

 

When the query for a delegation zone is received, the server first resolves the FQDN of the name server, and then forwards the query to the resolved IP address (which may or may not be the same specified on the zone name server list). The server may recursively query for the name server FQDN if it is no authoritative for the the domain

 

Can you share a few more details:

 

1. What are the FQDN for the authoritative and delegation zones

2. What are the FQDN for the corresponding name servers

3. Is the Grid authoritative for the name server's domain

 

(feel free to use aliases for unique names)

 

From the tcpdump, did you see the resolution action for the above name servers? Is the answer received pointing to the correct IP address?

 

Thanks

Re: Delegation zone not working

Techie
Posts: 2
3825     0

Hi,

 

First of all thanks for replaying!

 

Here we have a authoritative DNS for:

mycomapny;

 

Then a delegation zone for:

myothercompany with NS: other-dns with ip 1.1.1.1

 

Until here everything works fine.

 

But then I've configured a new delegation zone:

mynewcompany with NS: new-dns with ip: 2.2.2.2

 

When I try to resolve something on mynewcompany, the Authoritative NS send the request to 1.1.1.1 instead of 2.2.2.2 as I've configured. Then I receive NX domain as expected...

 

So I feel I am missing something on the configuration but both delegation zones are exactly the same configure but of course with its own NS server.

 

On the tcpdump I can see the authoritative server does not send any packet towards 2.2.2.2, it is like if only 1.1.1.1 were configured.

 

Thanks in advance for your help!

Re: Delegation zone not working

Moderator
Moderator
Posts: 45
3825     0

Hi There,

 

It would be easier if we could use FQDN’s for this, as follows perhaps;

 

mycompany - test.com

myothercompany – sample1.test.com

mynewcompany – sample2.test.com ?

 

 

Now let’s assume that your Authoritative Zone is “test.com”.

 

And you have created a Delegation Zone “sample1.test.com” under “test.com” and delegated it to the NS “ns1.example.com”.

 

You mentioned that till here it is working fine [?].

 

Now the new delegation zone that you have created, would it be “sample2.test.com” ?

 

If yes, could you confirm if the Name Server to which this is delegated to say “ns2.example.com” – 2.2.2.2 is resolvable by your DNS server?

 

Even when you have configured the new delegations NS with the IP 2.2.2.2, the DNS Server should be capable of resolving the NS’s FQDN before it can send the respective queries towards it.

 

So if it is not resolvable, you can try creating an A record for the NS, “ns2.example.com”, of the delegation zone in question.

 

Hope this helps. Please do correct me if I have misunderstood your configuration.

 

Regards.

Showing results for 
Search instead for 
Did you mean: 

Recommended for You