Reply

Getting rcode:9 alert for server

kuldeepsingh
Techie
Posts: 1
559     0

Error:

 

Alert:800904 - HLBWADDCP003.abc.xyz.comThe dynamic registration of the DNS record '_ldap._tcp.Manhattan-NY._sites.gc._msdcs.xyz.com. 600 IN SRV 0 100 3268 HLBWADDCP003.abc.xyz.com.' failed on the following DNS server:    DNS server IP address: 192.168.131.58  Returned Response Code (RCODE): 9  Returned Status Code: 9009    For computers and users to locate this domain controller, this record must be registered in DNS.    USER ACTION   Determine what might have caused this failure, resolve the problem, and initiate registration of the DNS records by the domain controller. To determine what might have caused this failure, run DCDiag.exe. To learn more about DCDiag.exe, see Help and Support Center. To initiate registration of the DNS records by this domain  controller, run 'nltest.exe /dsregdns' from the command prompt on the domain controller or restart Net Logon service.    Or, you can manually add this record to DNS, but it is not recommended.    ADDITIONAL DATA  Error Value: %%9009

Re: Getting rcode:9 alert for server

[ Edited ]
Adviser
Posts: 77
560     0

Hello Kuldeep,

 

I understand that the Domain controller is unable to register its service records in Infoblox. Can you please start a traffic capture on the configured Infoblox DNS server to confirm that these requests are reaching Infoblox during the DC’s netlogon restart ?

 

Can you please validate this configuration :

  

Go to Data management -> DNS -> Select the AD domain under which the underscore zones are expected to be updated -> Check if this specific DC is added under ‘Allow unsigned updates from Domain Controllers’ &  ‘Automatically create underscore zones’ is indeed enabled ?

  

Looking at the error code, I suspect whether the DC is pointing the update to the expected DNS server or not. In that case as I mentioned, a traffic capture would help you considerably.

 

Additional note :  

 

Does these Domain controllers have Symantec End Point Software/SEP v14 installed ? Just a random guess : Looking at https://support.symantec.com/en_US/article.TECH236543.html I see that there is a critical defect with this SEP version & it may result in this state as well.

 

Please let me know how it goes.

  

Best regards,

Mohammed Alman.

Showing results for 
Search instead for 
Do you mean 

Recommended for You