Reply

Separate Default Route for LAN1 vs LAN2

mconlogue
Techie
Posts: 2
3342     0

We currently have two grid members just using LAN1 that responds to all internal DNS and DHCP requests direct from our end users.

 

I want to enable LAN2 port for DNS with a different IP address that hangs off of a zone of our firewall, and I want to enable Anycast.  LAN1 will stay active with its current IP and will be enabled for both DNS and DHCP.

 

I would like this to work so that if I am an end user and I make a DNS query to the IP of LAN1 then Infoblox will send the response back out LAN1.  

Likewise if from the same end user and I make a DNS query to the IP of LAN2 (or to the AnyCast address) then the Infoblox will send the response back out on LAN2 (not LAN1).

 

In order to do this I need to have separate default routes assigned to each interface which looks like it is doable based on page 476 of the 7.3 Admin guide. It talks about being able to have a different default route for each interface & a separate default route for the default routing table in the box.  

Although the example on page 476 shows this being done, I don't see how adding the additional static routes is done?

Thanks

 

 

Re: Separate Default Route for LAN1 vs LAN2

Authority
Posts: 20
3343     0

Go to Grid > Grid Manager > Members

 

Check the box on a Grid Member and Edit.

 

Go to Network and click on the advanced tab (make sure you've toggled advanced mode)

 

You can add IPv4 and IPv6 routes there...

Re: Separate Default Route for LAN1 vs LAN2

TVillinger
Techie
Posts: 2
3343     0

Did adding the static route to your DNS appliance address the question you posed. I have the same type of deployment where my LAN1 interfaces neighbor is router 1 and my LAN2 interfaces neighbor is router 2. The issue I am experiencing is when my primary router 1 goes down. My Anycast seems to go into a blackhole state. The physical LAN1 on my appliance never goes down as it goes through a switch, then up to router 1. It seems like my endusers queries are coming in via my LAN2 interface, but the responses are going out LAN1. Curious if it solved your situation. If so, then I need to figure out what default route should be.  

manage to Re: Separate Default Route for LAN1 vs LAN2

yyye
Techie
Posts: 6
3343     0

Did you manage to sort out the issue , Please advise i have same issue

Showing results for 
Search instead for 
Do you mean 

Recommended for You