Reply

What is the best practice for setting "DNS Resolvers" for Infoblox?

Techie
Posts: 3
6204     0

When enabling DNS resolution on the Infoblox appliance, you can specify a network server to perform domain name queries and specify up to two name servers for resolving a DNS name. You can specify the IP address of a preferred name server and that of an alternate name server.

 

My question is... Is it a good or bad practice point an Infoblox appliance to itself as the perfered or alternate name server under the "DNS Resolver" section of the Grid\Member properties?

 

Thank you,

Re: What is the best practice for setting "DNS Resolvers" for Infoblox?

Moderator
Moderator
Posts: 66
6205     0

Hi Nfullenkamp,

 

 "DNS Resolver" is used for resolving FQDN by demons other than named, for example, if NTP is configured using an FQDN rather than an IP. If we haven't configured the same the appliance will use the loopback interface 127.0.01 as the preferred resolver.

 

It depends on your network architecture and configuration whether you use a different server or itself. Both cases do not have any specific advantage/disadvantage over the other. If you are not specifying anything it will use loopback, in such a case check if it falls to the desired view.

 

Let me know if this helps

 

Regards,

Syam.

Re: What is the best practice for setting "DNS Resolvers" for Infoblox?

Adviser
Posts: 77
6205     0

127.0.0.1 is not always the best solution. To my inderstanding, the passive member of an HA pair does not serve DNS. So if the passive needs to resolve something, it can't. I always configure the VIP for an HA pair as the resolver.

Regards, Harry

Re: What is the best practice for setting "DNS Resolvers" for Infoblox?

Techie
Posts: 3
6205     0

If I am understanding you correctly you are saying if I do not specify anything and leave the list empty it will default to itself?  I’m not sure this is the case, or perhaps I misunderstood.  It appears that if I do that, it gives me an error and I must enter an IP or uncheck “Enable DNS Resolver”.  So if I want it to use itself it looks like I must enter its own IP or 127.0.0.1. 

 

This does help.

 

Thank you,

Showing results for 
Search instead for 
Did you mean: 

Recommended for You