Reply

cannot set non standard remote port on forwarding/stub zones

maxadamo
Techie
Posts: 8
2852     0

Hello, 

 

I can't seem to find a way to use a port other than 53 for the remote servers, either with Forwarder and Stub zones. 

I wanted to point directly to Consul, which uses port 8600, and I tried both semicolon and hash separator:

<IP_address>:5600

<IP_address>#5600

 

but infoblox throws an error and doesn't allow me to save such configuration. 

 

 

 

Re: cannot set non standard remote port on forwarding/stub zones

TTiscareno Community Manager
Community Manager
Posts: 361
2853     0

Infoblox validates data entered in various fields so anything which is not valid will trigger an error such as what you are seeing here. With DNS, queries for an A record can only receive an IP address in response and this is per the specifications for the DNS protocol, which Infoblox enforces.

 

From the details that you provided, I would assume that you are trying to also include the port number that clients must use to connect to your Consul server. This is something that is not supported in the DNS protocol and would instead be done via a redirect on a web server, or possibly load balancer.

 

Regards,

Tony

Re: cannot set non standard remote port on forwarding/stub zones

maxadamo
Techie
Posts: 8
2853     0

Hello Tony,

 

I do not agree your reply.

It's possible to specify a different port in Bind, Unbound, it's also possible to use a different port whith dig and nslookup.

Instead of saying "it's not supported in the DNS protocol", I'd thather say "it's not supported by Infoblox". 

Re: cannot set non standard remote port on forwarding/stub zones

maxadamo
Techie
Posts: 8
2853     0

I know already how to forward with iptables, how to put Bind in fron and so on. But I was expecting Infoblox to provide support for Service Discovery. 

Re: cannot set non standard remote port on forwarding/stub zones

maxadamo
Techie
Posts: 8
2853     0

And this a pieace of log from Infoblox. You can see the port number at the end (which mean you can have a port other than default): 

 

2018-12-30T18:24:42+00:00 daemon xxxxx,net named[21100]: info lame server resolving 'puppet.service.xxx.xxx.net' (in 'service.ha.xxxx.net'?): 2001:xx:xx::xx3#53

Re: cannot set non standard remote port on forwarding/stub zones

TTiscareno Community Manager
Community Manager
Posts: 361
2853     0

@maxadamo wrote:

Hello Tony,

 

I do not agree your reply.

It's possible to specify a different port in Bind, Unbound, it's also possible to use a different port whith dig and nslookup.

Instead of saying "it's not supported in the DNS protocol", I'd thather say "it's not supported by Infoblox". 


I may have misunderstood your question as I thought you were referring to how to control what port is used for queries through a conditional forwarding setup. Infoblox does allow you to set the source port that it will use for DNS services and you can find details regarding this in the section titled "Specifying Port Settings for DNS" in the NIOS Administrators Guide.

 

Regards,

Tony



Re: cannot set non standard remote port on forwarding/stub zones

maxadamo
Techie
Posts: 8
2853     0

@TTiscareno wrote:

@maxadamo wrote:

Hello Tony,

 

I do not agree your reply.

It's possible to specify a different port in Bind, Unbound, it's also possible to use a different port whith dig and nslookup.

Instead of saying "it's not supported in the DNS protocol", I'd thather say "it's not supported by Infoblox". 


I may have misunderstood your question as I thought you were referring to how to control what port is used for queries through a conditional forwarding setup. Infoblox does allow you to set the source port that it will use for DNS services and you can find details regarding this in the section titled "Specifying Port Settings for DNS" in the NIOS Administrators Guide.

 

Regards,

Tony



I'm sorry if I am not being very clear. I want to do with Infoblox, the same thing that I am alraedy doing with Bind (and have done in the past with Unbound). 

I have Bind listening on port 53, have Consul listening on port 8500. 

Bind is forwarding the queries to Consul on port 8500. With Unbound I was doing the same. 

Are Bind, Unbound and Consul doing something which is not supported in the protocol? 

 

regards

Massimiliano


 

Re: cannot set non standard remote port on forwarding/stub zones

maxadamo
Techie
Posts: 8
2853     0

@TTiscareno wrote:

I may have misunderstood your question as I thought you were referring to how to control what port is used for queries through a conditional forwarding setup. Infoblox does allow you to set the source port that it will use for DNS services and you can find details regarding this in the section titled "Specifying Port Settings for DNS" in the NIOS Administrators Guide.

 

Regards,

Tony



I'm sorry if I am not being very clear. I want to do with Infoblox, the same thing that I am alraedy doing with Bind (and have done in the past with Unbound). 

I have Bind listening on port 53, have Consul listening on port 8500. 

Bind is forwarding the queries to Consul on port 8500. With Unbound I was doing the same. 

Are Bind, Unbound and Consul doing something which is not supported in the protocol? 

 

regards

Massimiliano


 

Showing results for 
Search instead for 
Do you mean 

Recommended for You