Network Change & Configuration Management

Reply
Highlighted
Accepted Solution

HTTP 500 SSL negotiation Failed

Authority
Posts: 37
523     0

I have recently upgraded to 7.3.1 and added the new API version 3.3.0.0 to the Windows server.

I had a test script that worked in previous versions (although I cant remember the last time I tried them).

 

However, when I run the Perl script, it responds with 

HTTP 500 SSL negotiation Failed: https://<IPaddress>/api/base_uri.json?version=2.0.0 at Practice_API_Calls.pl line 126.

 

Line 126 refers to;

my $netmri = new NetMRI::API( api_version=>'auto', username=>'user', password=>'password', url=>'IPaddress');

 

This is an area I dont have much experience with so any suggestions would be helpful.

 

 

Thanks

 

Russ

 

Re: HTTP 500 SSL negotiation Failed

Authority
Posts: 37
524     0

Forgot to mention that I have the line, $ENV{'PERL_LWP_SSL_VERIFY_HOSTNAME'} = 0;

 

Running on Windows2008 R2 server.

 

 

Re: HTTP 500 SSL negotiation Failed

[ Edited ]
Ingmar Community Manager
Community Manager
Posts: 24
524     0

Russ,

 

Which version of Perl and in particular, which version of SSLeay? 

We did not make any recent changes that would cause this to be introduced

 

(edit: poor grammar)

 

Re: HTTP 500 SSL negotiation Failed

Expert
Posts: 228
524     0

We did learn that 7.3.1 dropped support for a couple really old ciphers, but Windows 2008 shouldn't have that limitation.  Perhaps it's due to this advisory in the 7.3.1 release notes:

 

"If using external authentication over SSL, ensure it supports TLS 1.2. prior to upgrading NetMRI."

Re: HTTP 500 SSL negotiation Failed

Authority
Posts: 37
524     0

Hi Ingmar, 

Thanks for the prompt. Pointed me in the right direction - realised that there were 2 different versions of Perl. Pointed the scripts and IIS handler mapping to the newer (Strawberry Perl) and this fixed the issue.

 

Currently the version of OpenSSL is 1.0.2h - at least thats the one in the Windows environment. Not sure if this is impacting the API calls - seems to pull the data correctly now.

 

Regds

 

Russ

Showing results for 
Search instead for 
Do you mean 

Recommended for You