Reply
Highlighted

NetMRI password change script

smang10
Techie
Posts: 2
1175     0

Hello Everyone,

 

I am very new to scripting and was tasked to work on a script to change the password on our Cisco ASAs. When running the script I get an error regarding authentication information not found. Not sure where to look for this and where to go next. Below is the error and script.

 

 

+++ Looking up authentication information .............................. FAILED

*** ERROR: No authentication information found for device ***

 

 

Script-Filter:
$Vendor eq "Cisco"

Script-Variables:
$password password "Password"

########################################################################
Action:
Get Username

Action-Commands:
SET: $UpdateMade = "no"
show run | inc username

Output-Triggers:
Change Password

Trigger:
Change Password

Trigger-Variables:
$username word

Trigger-Template:
username [[$username]] .+

Trigger-Commands: {$UpdateMade eq "no"}
config t
SET: $UpdateMade = "yes"

Trigger-Commands:
username $username password 0 $password

########################################################################
Action:
End and Write Memory

Action-Commands: {$UpdateMade eq "yes"}
End
Write Mem

########################################################################

Re: NetMRI password change script

Adviser
Posts: 387
1176     0

It means for that device NetMRI does not have CLI access, check local ACL or add the CLI Creds in the Settings

Follow me on LinkedIn: https://www.linkedin.com/in/sifbaksh
Twitter: https://twitter.com/sifbaksh

Re: NetMRI password change script

smang10
Techie
Posts: 2
1176     0

I have added the credentials in the settings and still getting the same error.

Re: NetMRI password change script

Ingmar Community Manager
Community Manager
Posts: 36
1176     0

There are a couple possible explanations and solution to this.

 

  1. As Sif stated, NetMRI might not have a set of working credentials for that device
  2. The job might require User credentials, check advanced settings to see if this has been enable

An easy solution for this would be to go to your account settings, edit your account, enable "User CLI Credentials Enabled" and then specify a set of credentials to use for your account.

 

Showing results for 
Search instead for 
Do you mean 

Recommended for You