Reply

error when installing a DSB

Techie
Posts: 17
3475     0

I've written a very basic DSB to get NetMRI to recognize Lantronix power managers. Installing the DSB throws the following error.

 

Skipping <versionmap> definition with triggered value: []

 

Here is my versionmap tag in the DSB.

 

versionmap vendor="Lantronix" variable="slp1SystemVersion" var_match="/ Version (\S+)/" var_replace="$1" />

 

slp1SystemVersion is a MIB defined in one of the MIB files I inlclude in the DSB. The value of this MIB looks like this.

 

SecureLinx Power Manager Version 5.3j

 

Despite this error, the DSB installs but the OS version does not show up for the Lantronix devices in NetMRI. I really want to get the version string to appear in NetMRI but I don't know what to do about the error NetMRI is giving me.

 

Can anyone tell me why NetMRI is complaining about my versionmap tag and what I can do to fix it?

Re: error when installing a DSB

Techie
Posts: 17
3475     0

Just realized I didn't copy the open bracket in my versionmap definition. It really is there in my DSB. The versionmap tag looks like this.

 

<versionmap vendor="Lantronix" variable="slp1SystemVersion" var_match="/ Version (\S+)/" var_replace="$1" />

 

So no need to tell me I'm missing an open bracket.

Re: error when installing a DSB

[ Edited ]
Authority
Posts: 32
3475     0

 

It is complaining about a "triggered" value not being included in the versionmap tag.  Try this:

 

<versionmap vendor="Lantronix" variable="slp1SystemVersion" var_match="/ Version (\S+)/" var_replace="$1" triggered="always" />

 

(Using "always" means we will use this versionmap to determine the OS version in all cases, even if a version has already been determined from some other source.  The other option is "whenUnknown".)

 

 -Marc-

Re: error when installing a DSB

Techie
Posts: 17
3475     0

That did the trick. Thanks for the reply.

Showing results for 
Search instead for 
Did you mean: 

Recommended for You