Reply
Accepted Solution

Error when trying to configure data collector

Authority
Posts: 20
5267     0

I installed and configured the data collector per the instructions here:

 

https://www.infoblox.com/wp-content/uploads/infoblox-deployment-guide-implementing-infoblox-data-con...

 

I then configured my grid to allow registration and enabled all of the reporting settings. When I try to register the data collector I am now getting the following error:

 

data.destination.reporting.registration > register
Getting Grid Data Collector information... done.
Generating certificate for Splunk forwarder... done.
Signing Splunk forwarder certificate with the Grid... done.
Registering Data Collector with the Grid... Bad WAPI Request: Name length cannot exceed 64 characters

 

It doesn't appear to be related to the hostname or user names. 

 

Has anyone else seen this before?

 

Re: Error when trying to configure data collector

pqian
Techie
Posts: 7
5268     0

Hi. When you use "set banner" to give a name to Data Connector, please use one that is shorter than 64 characters.

Re: Error when trying to configure data collector

viswanre
Techie
Posts: 1
5268     0
Hi, I accidentally clicked on "Disable Cluster" and it got blacklisted and went under the "Disabled Cluster" tab. I am not getting g an option to restore but only delete. I tried all possible ways to re-registered it against the grid, but in vein. When I checked using info command from data.destination.reporting, it displays as "Grid registration error: Data Collector Cluster is currently blacklisted". I tried changing the mode to disabled and tried to unregister, but it throws an error "Unregistering Data Collector from Grid... Bad WAPI Request: Data Collector Cluster is not activated" and it doesn't allow me wen it's in forward and hold mode.

Re: Error when trying to configure data collector

Adviser
Posts: 92
5268     0

Hello Reshma,

 

Good to see you in the community. I don’t know whether your concern has been addressed. But I am expecting it to be resolved by now, since the error should only persist for “3*refresh interval” set in the data connector for synchronization with your Grid. If not, try the following to resolve your problem from the specific location :

 

data.source.grid>sync

 

This would synchronize your data collector to the Infoblox Grid & it is expected to pull the latest status. If you are very sure that this data collector is not listed in the “Disabled cluster” & if “Enable registration” has been checked, that should synch up your data collector with the grid once again. Type “status” from the same location to see the Grid details to be sure.

 

Please let us know if there are any problems.

 

All the best,

Mohammed Alman.

Showing results for 
Search instead for 
Do you mean 

Recommended for You