Reply
Highlighted

A record creation with WAPI : OK with nios 6.10, NOK with nios 6.8

MPons
Techie
Posts: 1
1547     0

Hi everybody,

 

I am currently doing some scripting with powershell and i encountered a problem:

i developed a little script for automating A and PTR record creation.

So far, it's working nice with nios 6.10 using WAPI set to 1.2.1.

But when used with another appliance with nios 6.8 wapi set to 1.2.1 i am having http 400 errors.

Here is a sample of the powershell script:

 

$PASS = ConvertTo-SecureString "bobleponge" -AsPlaintext -Force

$IDENTIF=New-Object System.Management.Automation.PSCredential bob, $PASS


Invoke-WebRequest -Uri "https://ipam.bob.leponge/wapi/v1.2.1/record:a" -Method Post -Body "{`"ipv4addr`":'10.173.0.2',`"name`":'testVM.my.domain'}" -ContentType "application/json" -Credential $IDENTIF

 

 

 

If someone  have an idea...

 

 

 

what's the error message ?

GHorne Community Manager
Community Manager
Posts: 254
1548     0

what's the error message ?

6.8 may not support version 1.2.1 of the WAPI

Showing results for 
Search instead for 
Do you mean 

Recommended for You