Reply
Highlighted

Infoblox API problem

MFaiz
Techie
Posts: 8
2769     0

Hi,

I'm using the API to retrieve a list of all the fixed address objects from a particular network like so:

 

my @fixed_addresses = $session->get(object => "Infoblox:Smiley Very HappyHCP::FixedAddr", network => "$network");
 
However whilst the first set of fixed addresses in the array are all from the correct network, the remainder of the array also contains what appears to be all the other fixed address objects in the database (i.e. from various different networks).
 
Is there something I'm missing here?
 
Thanks.
 

Re: Infoblox API problem

I-Team Employee
Employee
Posts: 186
2770     0

What version of NIOS are you working with here?

At the time you make the call, what's the value you're passing to network? 

 

Re: Infoblox API problem

MFaiz
Techie
Posts: 8
2770     0

Hi,

We're running 5.1r5-15-174686 (on Trinzic 1410 appliances).

The value that I'm passing is a string in the format 10.20.0.0/22.

I'm fairly sure that value/format is correct as it matches, for the first few hundred array values at least, the value of $fixed_address->network.

Thanks.

Re: Infoblox API problem

PReilly
Techie
Posts: 5
2770     0

Hi Viper,

Did you find a solution to this? I have the same problem.

Thanks

Re: Infoblox API problem

MFaiz
Techie
Posts: 8
2770     0

Hi,

I'm afraid not. We have an update pending though so I'll try again once we're on 6.6.7 after next Tuesday and feedback what I find.

Best regards.

Re: Infoblox API problem

MFaiz
Techie
Posts: 8
2770     0

Well we've updated to NIOS v6.6.8 and the behaviour still persists so I guess we'll just have to work around it.

Re: Infoblox API problem

I-Team Employee
Employee
Posts: 186
2770     0

I would also file a ticket with support on it as a possible bug, so it can be evaluated and fixed if it is. 

 

Re: Infoblox API problem

Posts: 11
2770     0

I tried this in different version and could not reproduce this. Can you try search instead of get ?

Re: Infoblox API problem

MFaiz
Techie
Posts: 8
2770     0

Hi,

That works Smiley Happy I used the exact same parameters, simply replaced the "$session->get" with a "$session->search". Thanks!

Showing results for 
Search instead for 
Do you mean 

Recommended for You