Security

Reply
Highlighted
Accepted Solution

[NetMRI] Could not evaluate rule logic

dgttn
Techie
Posts: 7
2882     0

Hello,

 

I need your help for my appliance NetMRI in compliance.

I have a policy using the raw XML editor and I have deployed this policy for a group.

NetMRI using this policy for check the compliance of my devices on this group.

But, the result of check for certain devices finished with status UNKNOWN..

Error message : Could not evaluate rule logic: No running configuration is available for this device.

However, on device viewer -> Configuration management I have the configuration file !

And when I run the policy manually, with the same device, I have a good result of compliance (pass, error, warning, ...)

 

Thank you for you help.

Regards

 

 

 

Re: [NetMRI] Could not evaluate rule logic

Expert
Posts: 223
2883     0

I had a similar symptom for which I still have an open case.  One possible cauase was a race condition seen in 7.2.1 and 7.2.2 caused by a device becoming unlicensed and then quickly relicensed.  There is a hotfix for that.  But that was not my situation.

 

The cause of the "unknown", as listed in the PV detail was that the stored config was "out-of-date", even though SNMP polling (ccmHistory) showed that no changes had been made since the last stored revision.

Re: [NetMRI] Could not evaluate rule logic

Expert
Posts: 223
2883     0

BTW, this topic really belongs in the Network Automation forum, not Security.

Re: [NetMRI] Could not evaluate rule logic

Adviser
Posts: 357
2883     0
You should open a case for this.

Re: [NetMRI] Could not evaluate rule logic

dgttn
Techie
Posts: 7
2883     0

Thank you.

 

I have also the devices with error message :

Could not evaluate rule logic: The running configuration for device is out-of-date. 
Last Retrieval Attempt: 2018-04-17 21:00:37 +0100, Last Successful Retrieval: , Running Config Last Change as reported by SNMP: 2018-03-20 19:01:20 +0100

 

Re: [NetMRI] Could not evaluate rule logic

Adviser
Posts: 357
2883     0
That means it has never successfully gotten the configs. If you are seeing configs in the UI, then again you need a case. If not, then it is probably a CLI credentials issue.

Re: [NetMRI] Could not evaluate rule logic

dgttn
Techie
Posts: 7
2883     0

Thank you.

Yes, I have the configs in the UI. But the same error message.

So, I have open a case for this issue.

 

Regards.

Showing results for 
Search instead for 
Do you mean 

Recommended for You