Infoblox Community
Reply
Highlighted

Configuring Infoblox IPAM plug-in 4.0 with vRealize Automation 7.1

[ Edited ]
Community Manager
Posts: 267
Registered: ‎06-17-2015
EricS Community Manager
Community Manager
Posts: 267

This video will show you step by step how to configure the Infoblox IPAM plug-in 4.0 to provide IPAM and DNS automation for VMs using vRA 7.1 and vRO 7.1. The video covers IPAM plug-in 4.0 configuration using both an Infoblox DDI “WAPI” user account as well as a “Cloud API” user account. It covers how IPAM plug-in 4.0 works with Infoblox Network Views and DNS Views. Moreover, it covers how IPAM plug-in 4.0 can work with NSX through vRA 7.1 to provision the IP address of an NSX load balancer to automate the process of load balancing HTTP traffic between two VMs. The video also covers vRA 7.1 scale-out and scale-in use cases and will end with a quick IPAM plug-in troubleshooting section.

 

 

If you appreciate my efforts, please give me a kudo ↓ or Accept as solution to help others find it faster.

Re: Configuring Infoblox IPAM plug-in 4.0 with vRealize Automation 7.1

Techie
Posts: 2
Registered: ‎01-05-2017
defman
Techie
Posts: 2
Hello Eric, Thank you for your guide, it's very useful to get anyone started with configuring a private cloud IaaS environment and integrate it with Infoblox. I do have a question though, is the 4.0.1 plugin fully compatible with vRA/vRO 7.2 as well? I've done all the configs, my tenant is properly configured, I do have a template in the catalog that would be provisioned otherwise well with VMware as the IPAM endpoint, but everytime I'm using the Infoblox Endpoint with the proper Network Profile it would throw out and error saying the "Host name is invalid (Workflow: Reserve IP in network/Validate inputs (item9)#56)" in Orchestrator and "IPAM Provider Error: {"code":1005,"message":"Error allocating IP address(es) because list of available IP ranges is exhausted"} (Dynamic Script Module name : throwIpamError#28)" in vRealize Automation 7.2. Everything should be properly configured as I used both the User Guide for 4.0.1 and your videos. Let me know if you have any ideas as I'm surely missing something here. Thank you!

Re: Configuring Infoblox IPAM plug-in 4.0 with vRealize Automation 7.1

Techie
Posts: 2
Registered: ‎01-05-2017
defman
Techie
Posts: 2
This is now fixed, the issue was caused by wrong data in the domain name field in Infoblox. Thanks!