Infoblox’s global team of threat hunters uncovers a DNS operation with the ability to bypass traditional security measures and control the Great Firewall of China. Read about “Muddling Meerkat” and the many other threat actors discovered by Infoblox Threat Intel here.

NIOS DNS DHCP IPAM

Reply

Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

Authority
Posts: 14
570     0

One of the greatest things about vRA/vRO Aria Automation and Orchestration is it's integrations. But it is unfortunate when major companies can't support each other in this integration.

For example, did you know that the Infoblox provided IPAM plugins for vRA/vRO does not match the currently VMware supported versions of Aria Automation and Orchestration? Infoblox only supports up to version 8.8.2
https://docs.infoblox.com/space/ipamvmware8x/52593758/Deployment+Requirements


8.8.2 was End of Life for VMware (by Broadcom) as of July of 2023
End of General Support for VMware vRealize Automation 8.8.2 (94310)

https://kb.vmware.com/s/article/94310

Currently supported versions:
Build numbers and versions for VMware Aria Automation (formerly VMware vRealize Automation) (2143850)
https://kb.vmware.com/s/article/2143850

I have been using this plugin integration for years and hope to continue.

Re: Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

Techie
Posts: 34
570     0

This is in the works.

Re: Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

[ Edited ]
Authority
Posts: 14
570     0

How soon?  I am currently unable to get support on what appears to be a bug:

2024-01-22 12:31:13.215 -07:00info__item_stack:/item27
2024-01-22 12:31:13.226 -07:00info__item_stack:/item2
2024-01-22 12:31:13.237 -07:00info__item_stack:/item1
2024-01-22 12:31:13.241 -07:00infoSearching for IPAM connection with id [LOCAL-Gridmaster] ...
2024-01-22 12:31:13.243 -07:00infoThe IPAM connection with id [LOCAL-Gridmaster] was not found in the plugin cache.
2024-01-22 12:31:13.251 -07:00info__item_stack:/item8
2024-01-22 12:31:13.258 -07:00info__item_stack:/item19
2024-01-22 12:31:13.261 -07:00infoThe IPAM connection to add:
	id: LOCAL-Gridmaster
	hostName: gridmaster.local.edu
	apiType: WAPI
	priority: 1
	defaultNetworkView: null
	defaultDnsView: null
2024-01-22 12:31:13.267 -07:00info__item_stack:/item9
2024-01-22 12:31:13.275 -07:00info__item_stack:/item15
2024-01-22 12:31:13.277 -07:00infoChecking connectivity to the IPAM endpoint [gridmaster.local.edu/WAPI] ...
2024-01-22 12:31:13.282 -07:00info__item_stack:/item12
2024-01-22 12:31:13.312 -07:00warningAn error has occurred while checking connection with Infoblox IPAM server. Detail: SSL certificate error. (Workflow:Create IPAM connection / isConnectionOnline (item12)#4)
2024-01-22 12:31:13.319 -07:00info__item_stack:/item17
2024-01-22 12:31:13.322 -07:00infoConnection to the IPAM endpoint [gridmaster.local.edu/WAPI]: Failed
2024-01-22 12:31:13.340 -07:00info__item_stack:/item10
2024-01-22 12:31:13.359 -07:00info__item_stack:/item6
2024-01-22 12:31:13.378 -07:00errorWorkflow execution stack:
***
item: 'Create IPAM connection/item6', state: 'failed', business state: 'null', exception: 'Failed: Ipam Connection Failed. Check logs for more details. (Workflow:Create IPAM connection / Set output (item10)#2)'
workflow: 'Create IPAM connection' (ce57a2cd-fe8a-4f5a-a28f-6155d05301e8) 
|  'attribute': name=attrErrorCode type=string value=Failed: Ipam Connection Failed. Check logs for more details. (Workflow:Create IPAM connection / Set output (item10)#2)
|  'attribute': name=attrInputConnection type=InfobloxIPAM:IpamConnection value=dunes://service.dunes.ch/CustomSDKObject?id='LOCAL-Gridmaster'&dunesName='InfobloxIPAM:IpamConnection'
|  'attribute': name=attrCachedConnection type=InfobloxIPAM:IpamConnection value=__NULL__
|  'attribute': name=attrTestConnection type=InfobloxIPAM:IpamConnection value=dunes://service.dunes.ch/CustomSDKObject?id='LOCAL-Gridmaster'&dunesName='InfobloxIPAM:IpamConnection'
|  'attribute': name=attrSaveConnection type=string value=
|  'attribute': name=attrRefreshSslContext type=boolean value=true
|  'input': name=id type=string value=LOCAL-Gridmaster
|  'input': name=url type=string value=https://gridmaster.local.edu
|  'input': name=username type=string value=myvrauser
|  'input': name=password type=SecureString value=__NULL__
|  'input': name=priority type=number value=1.0
|  'input': name=apiType type=InfobloxIPAM:IpamApiType value=dunes://service.dunes.ch/CustomSDKObject?id='WAPI'&dunesName='InfobloxIPAM:IpamApiType'
|  'output': name=ipamConnectionOut type=InfobloxIPAM:IpamConnection value=null
*** End of execution stack.

 

 

From the local vRO member node, using the connection string with curl, gridmaster.local.edu/WAPI fails.  But I can connect using the connection string gridmaster.local.edu/wapi.  But Infoblox support won't even look at this since I am at vRA 8.10.1. 

 

Sales team reports 2 quarters, or half a year.  I need to roll this project out this month.

Re: Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

Techie
Posts: 34
570     0

RFE-13191 is targeting vRA / vRO 8.11.X, 8.12 is planned for a later NIOS release. We are expecting this to be delivered in the summer, so yes 2 quarters.

Re: Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

[ Edited ]
Authority
Posts: 14
570     0

@Layer8 wrote:

RFE-13191 is targeting vRA / vRO 8.11.X, 8.12 is planned for a later NIOS release. We are expecting this to be delivered in the summer, so yes 2 quarters.



Just in time for VMware to stop supporting those versions.  This is unacceptable

Product Name

 

SaaS Monthly Release
On-Prem Release Date

 

On-Prem Build # -Version

 

On-Prem Installer Build # - Version

 

On-Prem End of General Support
Aria Automation 8.14.1November 20232023-11-2822830382 - 8.14.1.3347822857517 - 1.0.0.15932024-11-28
Aria Automation 8.14October 20232023-10-1922618990 - 8.14.0.3307922630473 - 1.0.0.15802024-10-19
Aria Automation 8.13.1August 20232023-09-0722360938 - 8.13.1.3234022395538 - 1.0.0.15452024-09-07
Aria Automation 8.13July 20232023-08-0322178981 - 8.13.0.3175922191255 - 1.0.0.15192024-08-03
Aria Automation 8.12.2June 20232023-06-2921949837 - 8.12.2.3132922003350 - 1.0.0.15132024-06-29
Aria Automation 8.12.1May 20232023-05-1821768489 - 8.12.1.31050N/A2024-05-18
Aria Automation 8.12April 20232023-04-2021622235 - 8.12.0.3072821628956 - 1.0.0.14882024-04-20
vRealize Automation 8.11.2March 20232023-03-2121452955 - 8.11.2.3005221471040 - 1.0.0.14472024-03-16
vRealize Automation 8.11.1February 20232023-02-2121309636 - 8.11.1.2953821329473 - 1.0.0.14202024-02-21
vRealize Automation 8.11December 20222023-01-1921128101 - 8.11.0.27829N/A2024-01-19

Re: Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

Techie
Posts: 34
570     0

In some cases there are large changes to the formats and content of the APIs between versions, which are relased nearly monthly... not exactly an easy target to hit. 

 

Infoblox intentionally do not deprecate API calls, for this exact reason. Yes, we release new ones for optimization, and with hotfixes we can kill vulnerable ones... but asking a vendor to support a monthly cadence for a free feature/integration is a big ask. This model causes attrition to vendors as it's a way to create a walled garden, and 'use our internal tool for that' etc.

 

However, we are under new leadership and aligning a new cloud strategy... including in some cases paying OEMs to build their integrations to our products. I'm unsure of VMWare's status in this hierarchy currently, but it is something we are aware of and are taking larger steps beyond just "hire more developers to do this thing" type deal. 

Re: Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

Authority
Posts: 14
570     0

I can understand not being able keep up.  But being told by Infoblox support that this was an "Unsupported Version" as a copout reason to close the support request, especially when shown that the issue was case sensitivity call between the Infoblox provided plug-in and the Infoblox provided version of NIOS is what is unacceptable.  "WAP"I vs "wapi" via curl. 

 


@Layer8 wrote:

In some cases there are large changes to the formats and content of the APIs between versions, which are relased nearly monthly... not exactly an easy target to hit. 

 

Infoblox intentionally do not deprecate API calls, for this exact reason. Yes, we release new ones for optimization, and with hotfixes we can kill vulnerable ones... but asking a vendor to support a monthly cadence for a free feature/integration is a big ask. This model causes attrition to vendors as it's a way to create a walled garden, and 'use our internal tool for that' etc.

 

However, we are under new leadership and aligning a new cloud strategy... including in some cases paying OEMs to build their integrations to our products. I'm unsure of VMWare's status in this hierarchy currently, but it is something we are aware of and are taking larger steps beyond just "hire more developers to do this thing" type deal. 


 

Re: Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

Techie
Posts: 34
570     0

I understand. I think the efforts required to 'support' something is a very involved process. We are talking about training, testing, instructors, and certification for hundreds of people on a rolling timeframe for something that does not return revenue to the business. Although that seems an easy fix, the knowledge required to be able to identify typeError issues in WAPI calls isn't your standard L3 tech always IMO. 

Re: Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

Authority
Posts: 14
570     0

So do we have an update when the typeError will be resolved?   Aria Automation / Orchestrator 8.16.2 is out now. 

Re: Infoblox support for vRA/vRO only valid for outdated/VMware unspported version 8.8.2

Techie
Posts: 34
571     0

Have you enrolled in EAP? Gives you a direct ear to PM to get the answers from the horse's mouth.

 

Just checked that JIRA Issue, there are related ones as well (IPAM plugins, etc.) that are all 'planned for' 9.0.4 and 9.0.5. The former is imminent and the latter is likely this calendar year. 

 

However, I am not seeing in the Jira workflow builder that it's actually marked resolved in a new issue. Did your account SA talk about getting field prioritization?

Showing results for 
Search instead for 
Did you mean: 

Recommended for You