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Support Central: #3411 - Clearing Cache Entries for a DNS Server
Wondering how to clear cache entries for a DNS server? Look no further. If you have questions or curious if there's a KB article available on a particular topic, post a comment and we'll search the library.
Problem Summary
Customer needs to clear cache entries for a DNS server.
Customer Environment
NIOS DNS appliances
Versions
NIOS 6.x and later
Cause
The DNS records are cached in the DNS server until the DNS cache TTL (time to live) expires. Sometimes the cached DNS records may no longer be accurate. In such cases, you can manually clear the old DNS cache data before the DNS cache TTL expires.
Resolution
Clearing the DNS Cache
To clear all the entries in the DNS cache:
1. Navigate to the Data Management tab, select the DNS tab > Members tab.
2. Select a member, expand the Toolbar and click Clear > Clear DNS Cache.
3. Click Yes in the Clear Cache Confirmation dialog box to clear DNS cache.
Clearing Cache for DNS Views
You can configure the NIOS appliance to clear cache of a specific DNS view. This feature clears cache entries of a specific DNS view that is associated with a specific DNS member.
To clear cache of a DNS view:
1. Navigate to the Data Management tab, select the DNS tab > Members tab.
2. Expand the Toolbar, click Clear > Clear View's Cache.
3. Specify the following in the Clear View's Cache dialog box:
-
Member: Click Select Member to select a member. If there are multiple members, the Member Selector dialog box is displayed, from which you can select a member. Click the required member name in the dialog box. You can also click Clear to clear the displayed member and select a new one.
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DNS View: Select a DNS View from the drop-down list. This drop-down list appears only when there are multiple DNS views in the network view.
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Click Clear Cache to clear the cache entries of the corresponding DNS View.
Clearing Domain Names from the DNS Cache
You can clear specific domain names from the DNS cache.
To clear a domain name:
1. From the Data Management tab, select the DNS tab > Members tab.
2. Expand the Toolbar, click Clear > Clear Domain Name.
3. Specify the following in the Clear Domain Name from Cache dialog box:
-
Domain Name: Enter a domain name you want to delete.
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Member: Click Select Member to select a member. If there are multiple members, the Member Selector dialog box is displayed, from which you can select a member. Click the required member name in the dialog box. You can also click Clear to clear the displayed member and select a new one.
-
DNS View: Select a DNS View from the drop-down list. This drop-down list appears only when there are multiple DNS views in the network view.
-
Click Clear Domain Name to clear the domain name from the cache.
In addition, you can log in to the Infoblox CLI and use the set dns flush command to clear the DNS cache data. You can clear the cache file from a DNS view or clear a specific entry from the cache file.
Syntax:
set dns flush all [dns_view]
set dns flush name <name> [dns_view]
Argument |
Description |
all |
Clears the cache file from the default view. |
dns_view |
Specifies a particular DNS viewto clear cache. |
name |
Clears a specific entry from the cache. |
Example
Clear the cache file from the default DNS view
Infoblox > set dns flush all
Clear a specific entry for a DNS view
Infoblox > set dns flush test.com default.dv15
Note: The DNS cache will automatically clear whenever there is restart of services due to any of the following reasons:
-
The DNS service is restarted
-
HA failover
-
Reboot
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