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Support Central: KB #122: Unable to delete auto-created record
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Problem Summary
DNS A record exists in the corresponding zone that is no longer needed, but unable to delete.
Customer Environment
Infoblox Grid running DNS service.
Version
Does not depend on NIOS version.
Cause
While editing DNS zone, you will find that some of the DNS resource records (RRs) will contain comments saying that they are "auto-created". Many potential reasons could lead to an auto-created A record, such as:
- A record that belongs to delegated server, when creating delegated zone. NIOS will create an A record if the FQDN of the delegated name server matches an authoritative zone in the NIOS database.
- Infoblox grid member has assigned a NAT IP. NIOS will create an A record associated with the NAT IP if the FQDN of the grid member matches an authoritative zone in the NIOS database.
- NIOS auto-creates an A record for every authoritative name server defined in an authoritative zone definition, if the FQDN of the authoritative name server matches an authoritative zone in the NIOS database.
- Node configured with "Other IP Address" defined in DNS views property of the node.
Resolution
Solutions:
- If the A record that belongs to the delegated server when creating the delegated zone: NIOS will create an A record if the FQDN of the delegated name server matches an authoritative zone in the NIOS database. Solution: Remove the NS record from the delegated zone definition for the A record that is no longer needed.
- Infoblox grid member has assigned a NAT IP. NIOS will create an A record associated with the NAT IP if the FQDN of the grid member matches an authoritative zone in the NIOS database. Solution: Remove NAT definition if not being used correctly.
- NIOS auto-creates an A record for every authoritative name server defined in an authoritative zone definition if the FQDN of the authoritative name server matches an authoritative zone in the NIOS database. Solution: Remove the NS record from the authoritative zone definition (or NS group) for the A record that is no longer valid.
- Node configured with "Other IP Address" defined in DNS views property of the node. Solution: Adjust IP address in following location:
-
- NIOS 5.x/6.x/7.x:
- Go to Data Management >> DNS >> Members >> Edit Member properties >> Toggle Advanced Mode >> Click DNS View and edit "Address of Member Used in DNS Views" >> Identify the view and make the change >> Save and Restart services.
NOTE: In some circumstances the record may exist twice, one with correct information and another with incorrect details. It may require temporarily removing the correct record or definition as well, in order to remove the incorrect record.
General option: use cli command to correct all auto-created NS/A records as follows:
Infoblox > set maintenancemode <ENTER>
Maintenance Mode > set dns-auto-gen check <ENTER>
scanning for auto-created resource records...
Once this command is running, hitting 'q' will cancel it. You must page through the output screens to successfully complete this command.
Maintenance Mode > set dns-auto-gen renew <ENTER>
scanning for auto-created resource records...
Once this command is running, hitting 'q' will cancel it. You must page through the output screens to successfully complete this command.