Infoblox’s global team of threat hunters uncovers a DNS operation with the ability to bypass traditional security measures and control the Great Firewall of China. Read about “Muddling Meerkat” and the many other threat actors discovered by Infoblox Threat Intel here.

API & Integration, DevOps,NetOps,SecOps

Reply

Export Objects network in CSV format file

New Member
Posts: 2
1111     0

Hi all,

I have two environments, one for testing and the other for production:
I get the csv file from the Test environment (about 30000 defined networks) after about 6 min of processing via wapi :
curl -k -u infoblox:infoblox -H 'content-type: application/json' -X POST --connect-timeout 1500 --max-time 1500 "https://ip_test/wapi/v2.9/fileop?_function =csv_export" -d '{"_object": "network" }'.

I use the the response token and link to get the generated export file . It works fine :-)

 

On the production environment I export the csv file with about 130,000 defined ipv4 network objects through the grid manager gui in about 20 min.

 

If I try to use the same curl command via wapi in production environment:

curl -k -u infoblox:infoblox -H 'content-type: application/json' -X POST --connect-timeout 1500 --max-time 1500 "https://ip_production/wapi/v2.9/fileop?_function =csv_export" -d '{"_object": "network" }'

then after 10 minutes it returns nothing (no token, no link to file) . There isn't FW between client and grid.
How can I see what happens?
Thank you

Flax

Re: Export Objects network in CSV format file

Superuser
Posts: 17
1112     0

Sounds like you're hitting some sort of timeout somewhere.

1) Have you tried making the request with PostMan to get a bit more visibility into the request?

2) Have you tried setting a Keep-Alive header in Curl so that the server side won't close the connection?

Re: Export Objects network in CSV format file

New Member
Posts: 2
1112     0

Hi GreenMotion,

thank you  and sorry for the late reply, I've been busy with something else :-)
I tried using all the parameters like
--keepalive-time 60
--connect-timeout  1500
--max-time 1500
It is confirmed that the client machine and the grid do not have a firewall.
the timeout always occurs after 10 min.!!
I insert a detail: from the Infoblox log it would seem that even after the timeout the file is generated but by now the connection is already closed (HTTP/1.1 500 Internal Server Error)
I'll post some details about the call, with -verbose mode,  below.
Do you have any idea what happened?
Thanks a lot for the support

Flaminio

 

About to connect() to ip address port 443 (#0)
*   Trying ip address...
* Connected to ip address (ip address) port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
* skipping SSL peer certificate verification
* SSL connection using TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
* Server certificate:
*       subject: C=IT,ST=Italy,L=Roma,O=Organizzation,OU=CIO,CN=10.204.105.156
*       start date: Jul 10 16:39:48 2008 GMT
*       expire date: Jul 22 16:39:48 2008 GMT
*       common name: 10.204.105.156
*       issuer: C=IT,ST=Italy,L=Roma,O=Organizzation,OU=CIO,CN=10.204.105.156
* Server auth using Basic with user 'infoblox'
> POST /wapi/v2.9/fileop?_function=csv_export HTTP/1.1
> Authorization: Basic aW5mb2Jsb3g6UHJvdmFJUEFNMDEh
> User-Agent: curl/7.29.0
> Host: ip address
> Accept: */*
> content-type: application/json
> Content-Length: 23
>

* upload completely sent off: 23 out of 23 bytes

< HTTP/1.1 500 Internal Server Error
< Date: Mon, 15 May 2023 17:48:20 GMT
< Strict-Transport-Security: max-age=31536000; includeSubDomains
< X-Frame-Options: SAMEORIGIN
< X-XSS-Protection: 1; mode=block
< X-Content-Type-Options: nosniff
< Referrer-Policy: no-referrer-when-downgrade
< Content-Security-Policy: default-src 'self' style-src 'self' 'unsafe-inline' 'unsafe-eval'
< Content-Length: 0
< Connection: close
< Content-Type: text/plain

 

 

Showing results for 
Search instead for 
Did you mean: 

Recommended for You