SSO Login is being implemented on this site. Existing users: Your existing password must be reset the first time you login using SSO. Click here to reset your password first before login. Your new username will be your email.

API & Integration, DevOps,NetOps,SecOps

Reply

Trouble installing infoblox-client Python module on Windows 10

Techie
Posts: 3
350     1

First, I have never had any trouble installing this module until this last time. I've installed it before on previous versions of Python with no trouble – Windows or Linux.

 

The error starts with this:

 

Building wheels for collected packages: netifaces
Building wheel for netifaces (setup.py) ... error
error: subprocess-exited-with-error

× python setup.py bdist_wheel did not run successfully.
│ exit code: 1
╰─> [5 lines of output]
running bdist_wheel
running build
running build_ext
building 'netifaces' extension
error: Microsoft Visual C++ 14.0 or greater

 

...

 

I know this has to do with the Python build tools but I don't understand what workaround I may have. Here's how the pip install failure ended:

 

building 'netifaces' extension
error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
error: legacy-install-failure

× Encountered error while trying to install package.
╰─> netifaces

 

Any suggestions for a workaround would be appreciated. I would really like to have some of these scripts run from my workstation and not always have to send them over to our Linux VM.

 

Kevin

Re: Trouble installing infoblox-client Python module on Windows 10

Member
Posts: 2
351     1

I've also had the same issues on windows install. I used this stackoverflow page to help install Visual Studio builds.  https://stackoverflow.com/questions/64261546/python-cant-install-packages

This cleared the C++ error, but still unable to configure netifaces.

 

I then had to use python 3.8 since 3.10 is not compatible.  I found a Github on this, I can't find it now.  But 3.10 is not compatible at the moment. So I created a virtual enviorment with 3.8

 

After that I was able to install the module in the virtual inviorment.  

Showing results for 
Search instead for 
Did you mean: 

Recommended for You