Learn How We Can Help You Keep Teleworkers Protected During the COVID-19 Crisis

API & Integration

Reply
Highlighted

infoblox-client 0.4.24 dependency question

Authority
Posts: 29
353     0

A few days ago infoblox-client 0.4.24 was released.

I wanted to update from 0.4.23 on my Ubuntu 18.04 and don't wanted to destroy OS-maintained packages. While doing this, I found that python-six 1.13 is required in the dependencies. But in Ubuntu there is only 1.11 available. Other OSes also don't deliver 1.13, e.g. in Debian 10 it's 1.12. That means six has to be upgraded outside the OS on nearly any Linux environment.

 

Question for the developers: Is six 1.13 really necessary? Do you use any features from 1.12 or 1.13?

Infoblox-client 0.4.23 was running fine with six 1.11...

Do you think it's save to modify the required dependency back to 1.11?

 

Highlighted

Re: infoblox-client 0.4.24 dependency question

Authority
Posts: 29
353     0

The recently released version 0.4.25 has the same dependencies.

 

@Infoblox: Any thoughts about this?

 

Highlighted

Re: infoblox-client 0.4.24 dependency question

Techie
Posts: 9
353     0

We’ve not changed anything in client version 0.4.25 with respect to python-six package (https://github.com/infobloxopen/infoblox-client/blob/master/HISTORY.rst). If you’ve been using the 0.4.23 version with six==1.11.0 and have not faced any issues, then it is fine to go ahead and install 0.4.25. Please check the release notes to identify the changes.

 

And looking at the change log in six repository(https://github.com/benjaminp/six/blob/master/CHANGES), they have not done changes after 1.11.0 wrt the methods we use in our client.

Highlighted

Re: infoblox-client 0.4.24 dependency question

Authority
Posts: 29
353     0

Thanks for the info!

No, I didn't see any issues with six 1.11. But I'm "only" running Ansible. No custom python scripts.

 

Can you lower the dependencies to 1.11 in the python repo without releasing a new version? Would be more convenient :-) At least until the next releases of Ubuntu and Debian arrive, probably with a more current six.

There is currently a pull request which suggests to set the dependency to >=1.14. https://github.com/infobloxopen/infoblox-client/pull/248

I asked the submitter whether or not this can be "lowered" to >=1.11...

 

Highlighted

Re: infoblox-client 0.4.24 dependency question

Authority
Posts: 29
354     0

The pull request was modified to set the version to >=1.11.0 and merged.

Now there is only a new pipy release necessary...

 

Highlighted

Re: infoblox-client 0.4.24 dependency question

Authority
Posts: 29
354     0

Infoblox! Yes, you! Did you read my last update?

It says: Please make a new release!

Which means: Please make a new release!

 

Thanks in advance!

 

Showing results for 
Search instead for 
Do you mean 

Recommended for You