Infoblox’s global team of threat hunters uncovers a DNS operation with the ability to bypass traditional security measures and control the Great Firewall of China. Read about “Muddling Meerkat” and the many other threat actors discovered by Infoblox Threat Intel here.

API & Integration, DevOps,NetOps,SecOps


Problems starting CSV Import via WAPI

Posts: 6
4724     0

Hi @all,


I´m trying to start a CSV import via the WAPI. Unfortunately I´m getting the following error message


"Error": "AdmConDataError: None (IBDataError: IB.Data:CSV Import file is not valid. First line of the file must be either a valid version number or a valid header line.

This is my import file. It is encoded in us-ascii which should be correct.




Importing this file via the WebGui works perfect.

Here are my commands to start the upload


curl -k -u XXX:XXX -H content-type:application/json -X POST '

curl -k -u XXX:XXX -H content-type:multipart-formdata -F file=@test8-UTF.csv

curl -k -u XXX:XXX -H content-type:application/json -X POST '' -d '{"action":"START","on_error":"CONTINUE","update_method":"OVERRIDE","separator":"COMMA","operation":"CUSTOM","token":<TOKEN>"}'



I shortend the last command because the token is less relevant.
Do you have any idea why I´m getting this error message?


kind regards


Re: Problems starting CSV Import via WAPI

Posts: 306
4725     0

The CSV exampe is formatted as a custom import type.  But you're specifying an override import.  The API guide doesn't offer CUSTOM as an import type for API.


You could try changing the import type from OVERRIDE to CUSTOM but that may not actually work.


... "update_method":"OVERRIDE" ...


Probably you need to change the CSV file to be a traditional import type, by removing the IMPORT-ACTION column.

Re: Problems starting CSV Import via WAPI

Posts: 6
4725     0

Thanks for your response.

You are right. Unfortunately only "Merge" and "Override" are supported values for "update_method". So I removed the column "IMPORT-ACTION". But I still get the same error message.


curl -k -u XXX:XXX -H 'content-type:application/json' -X POST "" -d '{"action":"START","on_error":"CONTINUE","update_method":"OVERRIDE","separator":"COMMA","operation":"INSERT","token":"'"$TOKEN"'"}'


This is my new import file:




Any other idea?



Showing results for 
Search instead for 
Did you mean: 

Recommended for You