Infoblox’s global team of threat hunters uncovers a DNS operation with the ability to bypass traditional security measures and control the Great Firewall of China. Read about “Muddling Meerkat” and the many other threat actors discovered by Infoblox Threat Intel here.

API & Integration, DevOps,NetOps,SecOps

Reply

GET + /wapi/v2.11.2/network?*City:='Reno' = Failure

Techie
Posts: 7
1507     0

/wapidoc/additional/extattrsearch.html#extattrs-search

 

says that if I form a query like this:

 

GET /wapi/v2.11.2/network?*Building:='Data Center'
.. it will return all of the networks matching 'Data Center'.
 
So took the format and substuited "Building" for "City" but it does not work.
 
Thoughts?

Re: GET + /wapi/v2.11.2/network?*City:='Reno' = Failure

Adviser
Posts: 181
1508     0

Hi,

 

Could you please post the API and the output you get?

 

Meanwhile, could you try the above WAPI without the quotes like below:

GET + /wapi/v2.11.2/network?_return_fields%2B=extattrs&*City:=Reno

 

Regards,

Krishna

Re: GET + /wapi/v2.11.2/network?*City:='Reno' = Failure

[ Edited ]
Techie
Posts: 7
1508     0

Thanks for the help.  As requested .. error with quotes:

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<list/>

without quotes (works):

/wapi/v2.11.2/network?*City:=Reno

and your example works as well:

/wapi/v2.11.2/network?_return_fields%2B=extattrs&*City:=Reno

However if I switch the city to one with a space in it, quotes fail but %20 for the space works.

 

Why does the wapidoc say use quote?

Showing results for 
Search instead for 
Did you mean: 

Recommended for You