SSO Login is being implemented on this site. Existing users: Your existing password must be reset the first time you login using SSO. Click here to reset your password first before login. Your new username will be your email.

API & Integration, DevOps,NetOps,SecOps

Reply

Trying to update a TTL record for a host record

Member
Posts: 1
9414     0

I'm having an issue changing the TTL record for a set of hosts in infoblox.

 

I'm able to receive the data

 

curl --tlsv1 --insecure --user 'userSmiley Tonguew' https://gridmaster/wapi/v2.9/record:host?name~=test_vs.com

 

curl --tlsv1 --insecure --user 'userSmiley Tonguew' -H "Content-Type: application/json" -X PUT https://GRIDMASTER/wapi/v2.9/record:host_ipv4addr/ZG5zLmhvc3RfYWRkcmVzcyQuX2RlZmF1bHQuY29tLm5iLnBpMi1haXQtZGV2LTgwX3ZzLjEwLjE2MC4xMzIuMzIu:1.1.1.1/test_vs.com/default -d '{"ttl": 14400}'

 

{ "Error": "AdmConProtoError: Unknown argument/field: 'ttl'",
"code": "Client.Ibap.Proto",
"text": "Unknown argument/field: 'ttl'"

 

Can someone point me inthe right direction

Re: Trying to update a TTL record for a host record

Adviser
Posts: 179
9414     0

Hello,

 

Looks like you are passing the object reference of the Host IPv4 address (record:host_ipv4addr/ZG5zLmhvc3RfYWRkcmVzcyQuX2RlZmF1bHQuY29tLm5iLnBpMi1haXQtZGV2LTgwX3ZzLjEwLjE2MC4xMzIuMzIu:1.1.1.1/test_vs.com/default). The TTL paramter needs to be changed on the host record instead. You can refer to the TTL section on page 39 in this guide for more details.

 

Thanks,

Krishna

Showing results for 
Search instead for 
Did you mean: 

Recommended for You