Are you interested in our Early Access Program (EAP)? This program allows you to preview code, test in your lab and provide feedback prior to General Availability (GA) release of all Infoblox products. If so, please click the link here.

NIOS DNS DHCP IPAM

Reply

DNS Cache setting not working

Techie
Posts: 4
283     0

Hi Folks,

Our client machines have Infoblox DNS IP configured as primary DNS servers which is on-prem.

On the Infoblox server, We have a zone that is configured as a forward zone, and forwarder servers are our AD server's IP,
We have updated the A record on AD and we have verified that the record is replicated in all Domain controllers. We verified this by doing nslookup.

But if we do the lookup from the client machine to the Infoblox servers the record is not updated, it is showing an old A record. we checked that the old record is still in the cache of the Infoblox server. We verified by Data management>>View>>Server cache

From the client machine, we tried to do ipconfig /flushdns multiple times but with no success.

But after clearing the cache from the Infoblox server it works properly and displays the updated A record.

We tried to change the parameter from DNS Properties >>Zone setting>>>TTL value and we changed to 1 second as well but with no success.

Can you please advise what can be the solution?

version of nios is 8.6.2

Re: DNS Cache setting not working

Superuser
Posts: 99
284     0

Hi,

Here the master nameserver was still on the AD, then if you would like to change the record TTL, you need to change it on the AD as master not in Infoblox as slave. then it should works.

Thanks

Re: DNS Cache setting not working

Techie
Posts: 4
284     0

Hi,

Yes, it could be a solution, also I found that from members you can also change the cache setting as well. Member ....General ....Advance...MAx cache TTL.

Thanks

Shaukat

Showing results for 
Search instead for 
Did you mean: 

Recommended for You