Introducing SOC Insights for BloxOne Threat Defense: Boost your SOC efficiency with AI-driven insights to eliminate manual work and accelerate investigation and response times. Read the blog announcement here.

NIOS DNS DHCP IPAM

Reply

Not able to GET custom DHCP options

New Member
Posts: 2
4971     0

I've created a custom option for a network range. The option number is 240, and it is a string value.

However, it's not appearing on the client side.

A network trace shows that this particular option is not in the offer packet (other options are visible).

How can I resolve this ?

 

 

 

Re: Not able to GET custom DHCP options

[ Edited ]
Moderator
Moderator
Posts: 72
4971     0

Greetings!

Please explain your configuration in detail so that we can understand better?

#1 - Did you navigate to DHCP-->Option Spaces tab, then created a new option space and specified 240 as string?
OR
#2 - Did you navigate to DHCP-->Option Spaces tab and added 240 into the default IPv4 option space named DHCP?

#2 above just requires you to specify your option at a range or network and provide its value.
#1 above requires you to create an IPv4 option filter, then match client(s) based on ther VCI (option 60) and apply the filter on a range as a Logic filter.


When you perform the network trace, do you find the client asking for option 240 inside the Parameter Request List (PRL - Option 55) in a DHCPDISCOVER packet?

If your requirement is such that Infoblox provide all configured option(s) on a range, to client(s), regardless of whether they are requesting or not would require you to enable "Ignore optionlist requested by client and return all defined options". This can be configured on a range/network and certain other places and configuring it simply means that Infoblox writes an additional statement to dhcpd.conf to ignore the PRL from clients.


Best Regards,

Bibin Thomas

Re: Not able to GET custom DHCP options

New Member
Posts: 2
4971     0

Hello Bibin.

 

Thank you very much for the reply, it was very educational and helped to resolve the issue.

Once we checked the "Ignore optionlist requested by client and return all defined options" option on the advanced tab, we got expected results.

 

Best Regards,

 

ujoshi

Re: Not able to GET custom DHCP options

Moderator
Moderator
Posts: 72
4971     0

Blur Background

Moderator
Moderator
Posts: 36
4972     0

Re: Not able to GET custom DHCP options

Moderator
Moderator
Posts: 36
4972     0

Re: Not able to GET custom DHCP options

New Member
Posts: 1
4972     0

So the option still did not show up on the MS server as a predefined option.

By adding the DHCP option Spaces under the DHCP IPV4,  is there another step to get that applied on all MS servers?

Dean

Re: Not able to GET custom DHCP options

New Member
Posts: 1
4972     0

Hi Team, 

We are trying to setup Custom Options, I created them in Option Space, is that the correct locaton to create them? 
2nd. I Created them in the Custom Option, added them to the network Scope as per screenshot, but the options are not being pushed to the devices. Any advise? 
attached the image for reference, any ideas, pretty urgent - thank you team

Need to create the following Custom Options

Name: WMS

Data Type - String

Code 165

Description WMS_Server

us1.wysemanagementsuite.com:443

2)

Name: 166 MQTT Server

Description: MQTT Server

String:

us1.wysemanagementsuite.com:1883

 

3) create the 167 Wyse Management Suite CA Validation server URL option tag, do the following:

Enter the following values, and click OK.

Name—CA Validation

Data type—String

Code—167

Description—CA Validation

Enter the following values, and click OK.

String: FALSE

4)

create the 199 Wyse Management Suite Group Token server URL option tag, do the following:

Enter the following values, and click OK.

Name—Group Token

Data type—String

Code—199

Description—Group Token

String: *******

Capture1.PNG



Re: Not able to GET custom DHCP options

New Member
Posts: 1
4972     0

Hello, I have similar issue but in my case the target DHCP option is option 120 for SIP server IP address. As default DHCP option doesn't include that option, I added that open to default DHCP option space or created new DHCP option space as below screenshot. But either option didn't work even after I tikced "Ignore optionlist requested by client and return all defined options"  

Users or IP Phones cannot get that DHCP Option. According ot Help, The code should be between 126 and 254 so this might be the reason this time. If that is the case, could anyone please share how to add non-default DHCP option 120 and activate it?

2023-08-14 163847.png

Thanks

Showing results for 
Search instead for 
Did you mean: 

Recommended for You